Opened 3 years ago

Closed 3 years ago

#19856 closed defect (fixed)

Gitian build for OS X is not matching on some machines

Reported by: gk Owned by: tbb-team
Priority: Very High Milestone:
Component: Applications/Tor Browser Version:
Severity: Critical Keywords: tbb-gitian, GeorgKoppen201608, TorBrowserTeam201609R
Cc: boklm Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

While building 6.5a2 I used a recently set up machine for building that showed differences on OpenSSL artifacts for OS X.

Child Tickets

Change History (9)

comment:1 Changed 3 years ago by gk

FWIW: I used KVM (using Debian Jessy) and testing with the LXC machine showed that the latter matched boklm's build.

comment:2 Changed 3 years ago by gk

Summary: Gitian build on OS X is not matching on some machinesGitian build for OS X is not matching on some machines

comment:3 Changed 3 years ago by gk

The plot thickens a bit: the stable series is not affected it seems. I get the same hashes on my newly set up build machine.

comment:4 Changed 3 years ago by boklm

Did you try rebuilding 6.5a2 on the same machine again, to see if you still get a different build, or if it was something only happening once?

comment:5 Changed 3 years ago by gk

Yes, rebuilding the OS X part just finished and I still get a different build. Thus, this is reproducible and happens only with the alphas.

comment:6 Changed 3 years ago by gk

Keywords: GeorgKoppen201608 TorBrowserTeam201608R added; TorBrowserTeam201608 removed
Status: newneeds_review

Bisecting gives me 3acd55740d447b2afb47ab5da5e3eece93337829 as the first bad commit. bug_19856 (https://gitweb.torproject.org/user/gk/tor-browser-bundle.git/commit/?h=bug_19856) has a possible fix reverting to libfaketime for the gitian-utils part for OS X which fixes the problem for me. I am open to better solutions, though, if we can get to one before we need to build the next alpha.

comment:7 Changed 3 years ago by gk

Keywords: TorBrowserTeam201609R added; TorBrowserTeam201608R removed

Moving review tickets to September

comment:8 Changed 3 years ago by boklm

As we don't have a better solution at the moment, reverting to libfaketime for this part looks like a good idea. The patch looks good.

comment:9 Changed 3 years ago by gk

Resolution: fixed
Status: needs_reviewclosed

Thanks. This is commit 73a698d2e1875763c153282a0eb19c259bd3788b on master.

Note: See TracTickets for help on using tickets.