#19869 closed defect (fixed)

tor_fragile_assert() in evdns_get_orig_address() on tor-0.2.9-alpha-1

Reported by: isis Owned by:
Priority: High Milestone: Tor: 0.2.9.x-final
Component: Core Tor/Tor Version: Tor: 0.2.9.1-alpha
Severity: Normal Keywords: isaremoved, regression, nickwants029, tor-guards-revamp, TorCoreTeam201610
Cc: isis, asn Actual Points:
Parent ID: Points: .1
Reviewer: isis Sponsor:

Description

 │ 15:29:14 [WARN] Bug:     /usr/bin/tor(+0x3ee39) [0x56051379ee39] (on Tor 0.2.9.1-alpha )
 │ 15:29:14 [WARN] Bug:     /lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf5) [0x7fa32c454b45] (on Tor 0.2.9.1-alpha )
 │ 15:29:14 [WARN] Bug:     /usr/bin/tor(main+0x19) [0x56051379ede9] (on Tor 0.2.9.1-alpha )
 │ 15:29:14 [WARN] Bug:     /usr/bin/tor(tor_main+0x1c25) [0x5605137a6cf5] (on Tor 0.2.9.1-alpha )
 │ 15:29:14 [WARN] Bug:     /usr/bin/tor(do_main_loop+0x294) [0x5605137a3494] (on Tor 0.2.9.1-alpha )
 │ 15:29:14 [WARN] Bug:     /usr/lib/x86_64-linux-gnu/libevent-2.0.so.5(event_base_loop+0x7fc) [0x7fa32d6a73dc] (on Tor 0.2.9.1-alpha )
 │ 15:29:14 [WARN] Bug:     /usr/bin/tor(+0x42451) [0x5605137a2451] (on Tor 0.2.9.1-alpha )
 │ 15:29:14 [WARN] Bug:     /usr/bin/tor(+0xf59e5) [0x5605138559e5] (on Tor 0.2.9.1-alpha )
 │ 15:29:14 [WARN] Bug:     /usr/bin/tor(+0xfe584) [0x56051385e584] (on Tor 0.2.9.1-alpha )
 │ 15:29:14 [WARN] Bug:     /usr/bin/tor(channel_tls_handle_cell+0x233) [0x56051381c303] (on Tor 0.2.9.1-alpha )
 │ 15:29:14 [WARN] Bug:     /usr/bin/tor(command_process_cell+0x280) [0x560513839ce0] (on Tor 0.2.9.1-alpha )
 │ 15:29:14 [WARN] Bug:     /usr/bin/tor(circuit_receive_relay_cell+0x2a9) [0x5605137c99e9] (on Tor 0.2.9.1-alpha )
 │ 15:29:14 [WARN] Bug:     /usr/bin/tor(+0x69673) [0x5605137c9673] (on Tor 0.2.9.1-alpha )
 │ 15:29:14 [WARN] Bug:     /usr/bin/tor(connection_ap_handshake_socks_resolved+0x9e) [0x56051385876e] (on Tor 0.2.9.1-alpha )
 │ 15:29:14 [WARN] Bug:     /usr/bin/tor(dnsserv_resolved+0x1dc) [0x56051388f76c] (on Tor 0.2.9.1-alpha )
 │ 15:29:14 [WARN] Bug:     /usr/bin/tor(tor_bug_occurred_+0xb7) [0x5605138be107] (on Tor 0.2.9.1-alpha )
 │ 15:29:14 [WARN] Bug:     /usr/bin/tor(log_backtrace+0x42) [0x5605138a56c2] (on Tor 0.2.9.1-alpha )
 │ 15:29:14 [WARN] Bug: Line unexpectedly reached at evdns_get_orig_address at ../src/or/dnsserv.c:292. Stack trace: (on Tor 0.2.9.1-alpha )
 │ 15:29:14 [WARN] tor_bug_occurred_(): Bug: ../src/or/dnsserv.c:292: evdns_get_orig_address: This line should not have been reached. (Future instances of this warning will be silenced.) (on Tor 0.2.9.1-alpha )

Possibly related to #18961.

Child Tickets

Change History (11)

comment:1 Changed 15 months ago by isabela

Keywords: isaremoved added
Milestone: Tor: 0.2.9.x-finalTor: 0.2.???

comment:2 Changed 14 months ago by nickm

Keywords: regression nickwants029 added

comment:3 Changed 14 months ago by nickm

Keywords: tor-guards-revamp added

Batch modification: I believe these are all (or nearly all!) required for the successful completion of the SponorU guards task.

comment:4 Changed 14 months ago by asn

Cc: asn added

comment:5 Changed 14 months ago by nickm

Keywords: TorCoreTeam201609 added; TorCoreTeam201608 removed

Move unassigned items in August to September.

comment:6 Changed 12 months ago by isis

Keywords: TorCoreTeam201610 added; TorCoreTeam201609 removed

This got left in September.

comment:7 Changed 12 months ago by isis

This is still present in 0.2.9.4-alpha-1:

Oct 26 14:38:45 sys-tor Tor[783]: Tor has successfully opened a circuit. Looks like client functionality is working.
Oct 26 14:38:45 sys-tor Tor[783]: Bootstrapped 100%: Done
Oct 26 14:38:48 sys-tor Tor[783]: tor_bug_occurred_(): Bug: ../src/or/dnsserv.c:294: evdns_get_orig_address: This line should not have been reached. (Future instances of this warnin
Oct 26 14:38:48 sys-tor Tor[783]: Bug: Line unexpectedly reached at evdns_get_orig_address at ../src/or/dnsserv.c:294. Stack trace: (on Tor 0.2.9.4-alpha 8b0755c9bb296ae2)
Oct 26 14:38:48 sys-tor Tor[783]: Bug:     /usr/bin/tor(log_backtrace+0x42) [0x556e06b5e692] (on Tor 0.2.9.4-alpha 8b0755c9bb296ae2)
Oct 26 14:38:48 sys-tor Tor[783]: Bug:     /usr/bin/tor(tor_bug_occurred_+0xb7) [0x556e06b77217] (on Tor 0.2.9.4-alpha 8b0755c9bb296ae2)
Oct 26 14:38:48 sys-tor Tor[783]: Bug:     /usr/bin/tor(dnsserv_resolved+0x1dc) [0x556e06b4871c] (on Tor 0.2.9.4-alpha 8b0755c9bb296ae2)
Oct 26 14:38:48 sys-tor Tor[783]: Bug:     /usr/bin/tor(connection_ap_handshake_socks_resolved+0x9e) [0x556e06b10d4e] (on Tor 0.2.9.4-alpha 8b0755c9bb296ae2)
Oct 26 14:38:48 sys-tor Tor[783]: Bug:     /usr/bin/tor(+0x6bcf3) [0x556e06a7ecf3] (on Tor 0.2.9.4-alpha 8b0755c9bb296ae2)
Oct 26 14:38:48 sys-tor Tor[783]: Bug:     /usr/bin/tor(circuit_receive_relay_cell+0x2a9) [0x556e06a7f069] (on Tor 0.2.9.4-alpha 8b0755c9bb296ae2)
Oct 26 14:38:48 sys-tor Tor[783]: Bug:     /usr/bin/tor(command_process_cell+0x280) [0x556e06af0dc0] (on Tor 0.2.9.4-alpha 8b0755c9bb296ae2)
Oct 26 14:38:48 sys-tor Tor[783]: Bug:     /usr/bin/tor(channel_tls_handle_cell+0x233) [0x556e06ad2ea3] (on Tor 0.2.9.4-alpha 8b0755c9bb296ae2)
Oct 26 14:38:48 sys-tor Tor[783]: Bug:     /usr/bin/tor(+0x103de4) [0x556e06b16de4] (on Tor 0.2.9.4-alpha 8b0755c9bb296ae2)
Oct 26 14:38:48 sys-tor Tor[783]: Bug:     /usr/bin/tor(+0xfafc5) [0x556e06b0dfc5] (on Tor 0.2.9.4-alpha 8b0755c9bb296ae2)
Oct 26 14:38:48 sys-tor Tor[783]: Bug:     /usr/bin/tor(+0x43231) [0x556e06a56231] (on Tor 0.2.9.4-alpha 8b0755c9bb296ae2)
Oct 26 14:38:48 sys-tor Tor[783]: Bug:     /usr/lib/x86_64-linux-gnu/libevent-2.0.so.5(event_base_loop+0x7fc) [0x7f252b3273dc] (on Tor 0.2.9.4-alpha 8b0755c9bb296ae2)
Oct 26 14:38:48 sys-tor Tor[783]: Bug:     /usr/bin/tor(do_main_loop+0x294) [0x556e06a57304] (on Tor 0.2.9.4-alpha 8b0755c9bb296ae2)
Oct 26 14:38:48 sys-tor Tor[783]: Bug:     /usr/bin/tor(tor_main+0x1c25) [0x556e06a5ab65] (on Tor 0.2.9.4-alpha 8b0755c9bb296ae2)
Oct 26 14:38:48 sys-tor Tor[783]: Bug:     /usr/bin/tor(main+0x19) [0x556e06a52c09] (on Tor 0.2.9.4-alpha 8b0755c9bb296ae2)
Oct 26 14:38:48 sys-tor Tor[783]: Bug:     /lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf5) [0x7f252a0d4b45] (on Tor 0.2.9.4-alpha 8b0755c9bb296ae2)
Oct 26 14:38:48 sys-tor Tor[783]: Bug:     /usr/bin/tor(+0x3fc59) [0x556e06a52c59] (on Tor 0.2.9.4-alpha 8b0755c9bb296ae2)

comment:8 Changed 12 months ago by nickm

Milestone: Tor: 0.2.???Tor: 0.2.9.x-final

comment:9 Changed 12 months ago by nickm

Points: .1
Status: newneeds_review

Well that was easy enough! This happens every time a hostname lookup over DNSPort fails.

See bug19869_029 in my public repository. Does that work for you?

comment:10 in reply to:  9 Changed 12 months ago by isis

Reviewer: isis
Status: needs_reviewmerge_ready

Replying to nickm:

Well that was easy enough! This happens every time a hostname lookup over DNSPort fails.

See bug19869_029 in my public repository. Does that work for you?

Okay, LGTM.

comment:11 Changed 12 months ago by nickm

Resolution: fixed
Status: merge_readyclosed

thanks; merged!

Note: See TracTickets for help on using tickets.