Opened 3 years ago

Closed 3 years ago

#19891 closed defect (duplicate)

"Update Firefox" bug in TBB

Reported by: b_meson Owned by: tbb-team
Priority: High Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I was running the latest TBB (6.0.3) and launched it but I was getting an error that "Firefox needs an update", which didn't make sense since Firefox is not running, the TBB fork of Firefox was. I checked the "Check for Tor Broswer Update" but it was not returning anything. I then re-downloading 6.0.3 and re-checked GPG keys (valid signatures) but was no longer seeing this pop-op.

Out of an abundance of caution, I took pcaps during the time of the popup and I noticed all the traffic was properly routed to nodes in the Tor network. I clicked the button and it routed me to the Tor Project webpage (no SSL warnings). I can provide pcaps if needed but @mrphs says it might be a simple bug in the updater.

Child Tickets

Attachments (1)

TBB603.png (42.9 KB) - added by b_meson 3 years ago.
screenshot of popup

Download all attachments as: .zip

Change History (3)

Changed 3 years ago by b_meson

Attachment: TBB603.png added

screenshot of popup

comment:1 Changed 3 years ago by mrphs

Component: User Experience/WebsiteApplications/Tor Browser
Owner: changed from Sebastian to tbb-team

gpg sig error worries me. can you please tell us where did you get your tor browser from?

comment:2 Changed 3 years ago by gk

Resolution: duplicate
Status: newclosed

Duplicate of #19890.

Note: See TracTickets for help on using tickets.