Opened 11 months ago

Closed 10 months ago

Last modified 10 months ago

#19902 closed defect (fixed)

Dual-install of libevent 1 and libevent 2 on openbsd confuses our autoconf logic

Reported by: nickm Owned by: nickm
Priority: Medium Milestone: Tor: 0.2.9.x-final
Component: Core Tor/Tor Version:
Severity: Normal Keywords: openbsd, review-group-8, regression
Cc: cb@… Actual Points: .2
Parent ID: Points: .2
Reviewer: Sponsor:

Description


Child Tickets

Change History (9)

comment:1 Changed 11 months ago by nickm

  • Owner set to nickm
  • Status changed from new to accepted

comment:2 Changed 11 months ago by nickm

  • Status changed from accepted to needs_review

I think the problem may be that we demand header files that exist only in libevent 2, but we accept libraries that only support libevent 1... until we finally link.

Possible fix in branch bug19902_try1 in my public repository. I claim we should merge it whether it fixes the issue on openbsd or not.

comment:3 Changed 11 months ago by nickm

  • Keywords review-group-7 added

comment:4 Changed 11 months ago by rubiate

  • Cc cb@… added

See my comment and patch on #19758, sorry I wasn't aware this had a separate ticket.

The patch in that branch wouldn't work because that whole conditional is being skipped.

comment:5 Changed 11 months ago by dgoulet

  • Status changed from needs_review to needs_revision

comment:6 Changed 10 months ago by nickm

  • Keywords review-group-8 added; review-group-7 removed

comment:7 Changed 10 months ago by nickm

Sorry for the delay here -- the first half-a-dozen times I looked at this, it looked wrong to me. But now I understand: I think this should work okay.

comment:8 Changed 10 months ago by nickm

  • Keywords regression added
  • Resolution set to fixed
  • Status changed from needs_revision to closed

comment:9 Changed 10 months ago by nickm

  • Actual Points set to .2
Note: See TracTickets for help on using tickets.