Opened 9 months ago

Closed 4 months ago

#19953 closed defect (fixed)

DataDirectoryGroupReadable does not take effect when relay enabled

Reported by: redfish Owned by: dgoulet
Priority: Medium Milestone: Tor: 0.3.0.x-final
Component: Core Tor Version: Tor: 0.2.8.6
Severity: Normal Keywords:
Cc: redfish@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Add 'DataDirectoryGroupReadable 1'
Permissions on /var/lib/tor are as expected: 0750

Now, uncomment 'ORPort 9001':
Permissions on /var/lib/tor briefly switch to 0750 but then back to 0700,
despite DataDirectoryGroupReadable being still set to 1.

The patch for Ticket #17562 that adds DataDirectoryGroupReadable option did not change all calls to check_private_dir:
https://trac.torproject.org/projects/tor/attachment/ticket/17562/0002-Introduce-DataDirectoryGroupReadable-boolean.patch

Patch that fixes the issue is attached to this ticket. But, ideally, should factor the check for data dir into a function, but I figured a dev can do that instead of me dabbling with the code.

Child Tickets

Attachments (1)

datadir-group-readable.patch (744 bytes) - added by redfish 9 months ago.
Patch that fixes the issue.

Download all attachments as: .zip

Change History (8)

Changed 9 months ago by redfish

Patch that fixes the issue.

comment:1 Changed 9 months ago by redfish

  • Cc redfish@… added

comment:2 Changed 9 months ago by nickm

  • Milestone set to Tor: 0.2.8.x-final
  • Status changed from new to needs_review

comment:3 Changed 8 months ago by nickm

  • Status changed from needs_review to needs_revision

This looks like it should be correct. I'll need a changes file and a unified diff in order to merge it.

comment:4 Changed 6 months ago by nickm

  • Milestone changed from Tor: 0.2.8.x-final to Tor: 0.3.0.x-final

comment:5 Changed 4 months ago by dgoulet

  • Owner set to dgoulet
  • Status changed from needs_revision to accepted

comment:6 Changed 4 months ago by dgoulet

  • Status changed from accepted to merge_ready

I've taken the patch as is and added changes file. The patch does fixes the issue.

See branch bug19953_030_01.

comment:7 Changed 4 months ago by nickm

  • Resolution set to fixed
  • Status changed from merge_ready to closed

merged!

Note: See TracTickets for help on using tickets.