Opened 13 months ago

Closed 3 months ago

#20000 closed project (worksforme)

Improve our release process: we need fewer surprises.

Reported by: nickm Owned by:
Priority: Medium Milestone: Tor: unspecified
Component: Core Tor/Tor Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description (last modified by nickm)

Apologies for submitting this with no text: I wanted to grab ticket #20000 while it was available.

This ticket will be about ways to improve our release process. My current major complaints about the last series have been:

  • 0.2.9 began too large, and took too long to get clarity on must vs should vs could.
  • 0.2.9 had us delay our freeze date by 1.5 months. Should we have seen that coming earlier?
  • During the 0.2.9 series, we managed to "forget about" too many items and have them "appear" on our radar with less flexibility than we'd like.
  • 0.2.8 took far too long between freeze and stability. Why?
  • 0.2.8 has had a nonzero number of post-release regressions
  • 0.2.7.7 never shipped, and probably shouldn't ship as it stands.
  • 0.2.7 is in a zombie state right now.
  • 0.2.7 shipped with a nonworking ed25519 voting algorithm.
  • Versions earlier than 0.2.7 should really be starting to decommision. Why are they still around? What can we do to get more uptake?

Child Tickets

Change History (4)

comment:1 Changed 13 months ago by nickm

Description: modified (diff)

comment:2 Changed 9 months ago by dgoulet

Keywords: triage-out-030-201612 added
Milestone: Tor: 0.3.0.x-finalTor: unspecified

Triaged out on December 2016 from 030 to Unspecified.

comment:3 Changed 4 months ago by nickm

Keywords: triage-out-030-201612 removed

comment:4 Changed 3 months ago by nickm

Resolution: worksforme
Status: newclosed

I believe 0.3.0 and 0.3.1 have been going much much better, due to sticking with deadlines, sharing the work, etc.

Note: See TracTickets for help on using tickets.