Opened 22 months ago

Closed 7 months ago

#20020 closed defect (fixed)

Strange Warning: "Couldn't add re-parsed router: Some certs on this router are expired."

Reported by: torland Owned by: nickm
Priority: Low Milestone: Tor: 0.3.3.x-final
Component: Core Tor/Tor Version: Tor: 0.2.8.7
Severity: Normal Keywords: prop220-fallout, usability, logging, relay, review-group-26
Cc: Actual Points:
Parent ID: Points: 1
Reviewer: dgoulet Sponsor:

Description

Today I updated my bridge to Tor 0.2.8.7 due to the upcoming bridge authority switch.

After some hours of operation I see in the log the following warning:

"Couldn't add re-parsed router: Some certs on this router are expired."

Can someone please explain what this warning means. Is this something I have to worry about?

Child Tickets

Change History (15)

comment:1 Changed 22 months ago by nickm

That's nothing to worry about, although it probably means that one of you (either you or the router) has a clock that is mis-set... or that the code has a bug. We should investigate.

comment:2 Changed 20 months ago by dgoulet

Milestone: Tor: 0.3.0.x-final

Just had that few days ago on my relay running git master f45a58148. Plausibly a warning that we could change to info. That warning has been in the code since 0.2.0 so we should at least fully understand why this is happening now.

comment:3 Changed 18 months ago by dgoulet

Keywords: triage-out-030-201612 added
Milestone: Tor: 0.3.0.x-finalTor: 0.3.1.x-final

Triaged out on December 2016 from 030 to 031.

comment:4 Changed 16 months ago by nickm

Points: 1

The right fix here is to improve the warning.

comment:5 Changed 16 months ago by nickm

Keywords: triaged-out-20170308 added
Milestone: Tor: 0.3.1.x-finalTor: unspecified

Deferring all 0.3.1 tickets with status == new, owner == nobody, sponsor == nobody, points > 0.5, and priority < high.

I'd still take patches for most of these -- there's just nobody currently lined up to work on them in this timeframe.

comment:6 Changed 13 months ago by nickm

Keywords: triage-out-030-201612 removed

comment:7 Changed 12 months ago by nickm

Keywords: prop220-fallout usability logging relay added; triaged-out-20170308 removed

comment:8 Changed 8 months ago by s7r

Confirmed this today on 0.3.2.2-alpha-dev (git-51e47481fc6f131d) hosting a bridge. Nothing seams to have happened besides the warn log message.

comment:9 Changed 8 months ago by nickm

Milestone: Tor: unspecifiedTor: 0.3.2.x-final

comment:10 Changed 7 months ago by nickm

Owner: set to nickm
Status: newaccepted

comment:11 Changed 7 months ago by nickm

Milestone: Tor: 0.3.2.x-finalTor: 0.3.3.x-final
Priority: MediumLow
Status: acceptedneeds_review

I have a patch against master that tries to make the message more helpful, and give more information about what we saw, in cases there is a real problem. Since this is a harmless issue that doesn't happen much, I'm not going to suggest a backport to 0.3.2.x.

The relevant branch is ticket20020.

comment:12 Changed 7 months ago by nickm

Keywords: review-group-26 added

Creating review-group-26.

comment:13 Changed 7 months ago by dgoulet

Reviewer: dgoulet

comment:14 Changed 7 months ago by dgoulet

Status: needs_reviewmerge_ready

lgtm;

comment:15 Changed 7 months ago by nickm

Resolution: fixed
Status: merge_readyclosed

merged to master!

Note: See TracTickets for help on using tickets.