Opened 3 years ago

Closed 3 years ago

#20109 closed defect (fixed)

something wrong with commit 41cc1f612bd2112ab7cec0cc4fdeb68c26e231bf

Reported by: cypherpunks Owned by: dgoulet
Priority: Medium Milestone: Tor: 0.2.9.x-final
Component: Core Tor/Tor Version:
Severity: Normal Keywords: regression, TorCoreTeam201609
Cc: teor Actual Points: 0.1
Parent ID: Points: 0.1
Reviewer: Sponsor:

Description

If DNSPort is set , it lokks like it has NoDNSRequest is always set as well , even if DNSRequest is appended :

[warn] Refusing to connect to hostname [scrubbed] because Port has NoDNSRequest set.

Child Tickets

Change History (8)

comment:1 Changed 3 years ago by cypherpunks

Component: Core TorCore Tor/Tor

comment:2 Changed 3 years ago by nickm

Cc: teor added
Keywords: regression added
Milestone: Tor: 0.2.9.x-final

comment:3 Changed 3 years ago by nickm

Cc: dgoulet added

comment:4 Changed 3 years ago by teor

This was probably caused by #18693.
It could help to have chutney tests for this feature as well - otherwise we could break it, and never know.

comment:5 Changed 3 years ago by dgoulet

Cc: dgoulet removed
Owner: set to dgoulet
Points: 0.1
Status: newaccepted

comment:6 Changed 3 years ago by orionwl

Same problem here. I have not set any NoDNSRequest but still get that error consistently. I bisected it to b311f82, last working commit is 45b4e63.

comment:7 Changed 3 years ago by dgoulet

Actual Points: 0.1
Keywords: TorCoreTeam201609 added
Status: acceptedneeds_review

Fix in bug20109_029_01.

(No changes file as this hasn't been released.)

comment:8 Changed 3 years ago by nickm

Resolution: fixed
Status: needs_reviewclosed

merged!

Note: See TracTickets for help on using tickets.