Opened 9 years ago

Closed 9 years ago

Last modified 22 months ago

#2011 closed defect (fixed)

Torbutton alpha Preferences dialog OK button does nothing

Reported by: rransom Owned by: mikeperry
Priority: Immediate Milestone: Torbutton: 1.3
Component: Applications/Torbutton Version: Torbutton: 1.3.0-alpha
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

In Torbutton 1.3.0-alpha on Firefox 3.6.10, the ‘Preferences’ dialog's ‘OK’ button does absolutely nothing when clicked. I see no way to change Torbutton's settings.

Child Tickets

Attachments (1)

fix.patch (1.4 KB) - added by chrisdoble 9 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 9 years ago by rransom

I see about:config now, but that's hardly user-friendly.

comment:2 Changed 9 years ago by rransom

git bisect tells me:

6d8932396b026b7db3b6bbb1434a8760136a6e94 is the first bad commit
commit 6d8932396b026b7db3b6bbb1434a8760136a6e94
Author: Mike Perry <mikeperry-git@fscked.org>
Date:   Thu Sep 30 05:43:50 2010 -0700

    Added smart ref spoofing

Jacob's transparent proxy support patches cause an exception when the ‘OK’ button is clicked, but they didn't introduce this ‘nothing happens’ bug.

comment:3 Changed 9 years ago by downie

Same apparently on OSX PPC FF2.
For instance, changing 'Do not write Non-Tor cookies to disk' has no effect if you close preferences and re-open - it reverts to the previous setting.

Changed 9 years ago by chrisdoble

Attachment: fix.patch added

comment:4 Changed 9 years ago by chrisdoble

I've attached a patch that fixes this bug.

It was caused by lines 550-1 in preferences.js that attempted to get the "torbutton_CustomReferer" and "torbutton_CustomRef" elements (and associated preferences) that were removed in the smart ref spoofing commit. I also fixed the exception mentioned above.

comment:5 Changed 9 years ago by mikeperry

Thanks for this patch! I will review it and get a release out ASAP (may be a little while. Am going to be MIA for 2-3 days).

comment:6 Changed 9 years ago by mikeperry

Status: newneeds_review

comment:7 Changed 9 years ago by mikeperry

I have applied this patch in master. I hope to have it out in 1.3.1, which should also support firefox 4.

comment:8 Changed 9 years ago by rransom

Resolution: fixed
Status: needs_reviewclosed

The patch was included in Torbutton 1.3.1 and works.

comment:9 Changed 9 years ago by downie

Resolution: fixed
Status: closedreopened

Any plans to backport to Torbutton for Firefox 2, at least in the next stable?

comment:10 Changed 9 years ago by rransom

Resolution: fixed
Status: reopenedclosed

comment:11 Changed 22 months ago by teor

Severity: Normal

Set all tickets without a severity to "Normal"

Note: See TracTickets for help on using tickets.