Opened 4 years ago

Closed 4 years ago

#20127 closed defect (duplicate)

hidden service won't work with local ipv6 address

Reported by: toralf Owned by:
Priority: Medium Milestone: Tor: 0.2.9.x-final
Component: Core Tor/Tor Version: Tor: 0.2.8.7
Severity: Normal Keywords: tor-hs, ipv6
Cc: Actual Points:
Parent ID: Points: 1
Reviewer: Sponsor:

Description

works fine:

HiddenServicePort 80 127.0.0.1:1234

doesn't work:

HiddenServicePort 80 [::1]:1234

Checked twice with a simple python http server:
https://github.com/toralf/torutils/blob/master/websvc.py
at a stable hardened Gentoo Linux (host speaks ipv4 and ipv6)

Child Tickets

Change History (2)

comment:1 Changed 4 years ago by nickm

Milestone: Tor: 0.2.9.x-final

comment:2 Changed 4 years ago by teor

Keywords: tor-hs ipv6 added
Points: 1
Resolution: duplicate
Status: newclosed

This is a duplicate of #18357 in 0.2.6.10, moving that ticket to 0.2.9.
It appears IPv6 HiddenServicePort was never implemented correctly.

Note: See TracTickets for help on using tickets.