Opened 3 years ago

Closed 3 years ago

#20145 closed defect (duplicate)

allow spaces within Unix domain socket paths (ControlPort and SocksPort)

Reported by: mcs Owned by:
Priority: Medium Milestone:
Component: Core Tor/Tor Version:
Severity: Normal Keywords:
Cc: brade, gk Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

We are adding Unix domain socket support to Tor Launcher and Torbutton (see #14270 and its child tickets). But there does not seem to be a way to configure a Unix domain socket path that contains a space character (spaces within path names are somewhat common on macOS at least).

When I include a space in a ControlPort or SocksPort directive, it is interpreted as the separator that precedes the flags.

If there is a way to do this, please tell me how.
If there is not currently a way, then please give me a hint as to how to fix it.

Child Tickets

Change History (3)

comment:1 Changed 3 years ago by mcs

Parent ID: #14270

comment:2 Changed 3 years ago by gk

Seems to be a duplicate of #18753?

comment:3 in reply to:  2 Changed 3 years ago by mcs

Parent ID: #14270
Resolution: duplicate
Status: newclosed

Replying to gk:

Seems to be a duplicate of #18753?

Yes. Thanks for finding the older ticket.

Note: See TracTickets for help on using tickets.