Opened 3 years ago

Closed 3 years ago

#20193 closed defect (not a bug)

OnionOO stops serving data after about 15MB

Reported by: teor Owned by:
Priority: Medium Milestone:
Component: Metrics/Onionoo Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

When I download the following URL from OnionOO:
https://onionoo.torproject.org/uptime?first_seen_days=7-&flag=V2Dir&type=relay&last_seen_days=-7
It should serve about ~100MB of data.

Instead, it serves around 15MB, and then stops serving data. I've checked this over Tor and directly, so it's not just my connection.

When using python to download, I see the following error:

  File "scripts/maint/updateFallbackDirs.py", line 338, in load_possibly_compressed_response_json
    return json.load(response)
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/json/__init__.py", line 287, in load
    return loads(fp.read(),
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/socket.py", line 355, in read
    data = self._sock.recv(rbufsize)
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/httplib.py", line 588, in read
    return self._read_chunked(amt)
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/httplib.py", line 648, in _read_chunked
    value.append(self._safe_read(amt))
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/httplib.py", line 705, in _safe_read
    raise IncompleteRead(''.join(s), amt)
httplib.IncompleteRead: IncompleteRead(532 bytes read, 7660 more expected)

Child Tickets

Change History (1)

comment:1 Changed 3 years ago by teor

Resolution: not a bug
Status: newclosed

I think this was just my internet connection. It worked fine on the two other internet connections I tried.

Note: See TracTickets for help on using tickets.