Opened 3 years ago

Closed 3 years ago

#20199 closed defect (not a bug)

auto-joining password-protected XMPP group chats does not work

Reported by: Digitalcourage Owned by:
Priority: Low Milestone:
Component: Archived/Tor Messenger Version:
Severity: Normal Keywords: messenger, xmpp
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Tor Messenger can auto-join XMPP group chats. However, when I start Tor Messenger, I puts password-protected chats on hold instead of prompting me for a password or retrieving the password from the built-in password manager.

Even worse, I found no way to activate the conversations that were put on hold. When I open them, an empty chat window is shown. All I can do is to to close them and re-open them via File → Join chat…, entering all details again.

While you are at it, in the Join chat dialogue, the default value for the Server field (irc.$XMPP_SERVER) is not very helpful. The customary value for XMPP is conference.$XMPP_SERVER.

(I'm sorry if this should go to Instantbird's bug tracker – it seems to be offline or closed, like the Instantbird wiki.)

Thanks!

Child Tickets

Change History (3)

comment:1 Changed 3 years ago by arlolra

Hmm, this should work but is pretty cumbersome. See https://bugzilla.mozilla.org/show_bug.cgi?id=954491

Try this,

Tools > Accounts > choose your XMPP account
Properties > Auto-Joined Channels

That should have a list of the rooms. The format should be,
conference.server/resource password, conference.otherserver/resource

Add the password after the server. Let us know if that worked for you.

comment:2 Changed 3 years ago by Digitalcourage

Amazingly, this trick works – with immediate effect. Any chance to make this more user-friendly?

comment:3 Changed 3 years ago by arlolra

Resolution: not a bug
Status: newclosed

Any chance to make this more user-friendly?

I spoke to the Instantbird folks and they agreed that password management in general needs to be improved, but there're no immediate plans. We want this too, but have to weigh it against all the other wants.

Thanks for adding your +1 here, and I'm glad it's working for you now.

Note: See TracTickets for help on using tickets.