Opened 3 years ago

Closed 3 years ago

#20253 closed defect (fixed)

Change Ruleset for HTTPS Everywhere

Reported by: cypherpunks Owned by: jsha
Priority: Very High Milestone:
Component: HTTPS Everywhere/EFF-HTTPS Everywhere Version:
Severity: Critical Keywords: ruleset, change, EFF-HTTPS
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

cjfe.org has incomplete HTTPS and the content management system we use doesn't have a free or inexpensive SSL option. I'm not an expert on this.

Anyhow, visitors to our site who use HTTPS are getting an error which tells them the page can't be trusted.

I think this is because in the EFF HTTPS Atlas we are listed as having a certificate when HTTPS is only now available on one portion of our site (the donate/membership portals where CC information is processed).

What do I need to change or what can be changed to fix this problem? Zero technical knowledge and not a whole lot of time to learn about this, but this is affecting traffic to our site.

Child Tickets

Change History (5)

comment:1 Changed 3 years ago by cypherpunks

The issue is that you're using a self signed cert which points to dnsme.
If you want a free/inexpensive solution I'd recommend setting up letsencrypt (https://letsencrypt.org/getting-started/) on the apache instance to resolve this.

comment:2 in reply to:  1 Changed 3 years ago by cypherpunks

Replying to cypherpunks:

The issue is that you're using a self signed cert which points to dnsme.
If you want a free/inexpensive solution I'd recommend setting up letsencrypt (https://letsencrypt.org/getting-started/) on the apache instance to resolve this.

Not an option for us. We don't have shell access as we use a simplified content management/constituent relations management service who only offer SSL capability for $1000/month. We need HTTPS everywhere to NOT include our website. This is killing our web traffic and the trustworthiness of our brand.

comment:3 Changed 3 years ago by cypherpunks

Severity: MajorCritical

comment:5 Changed 3 years ago by fuglede

Resolution: fixed
Status: newclosed

GitHub PR merged.

Note: See TracTickets for help on using tickets.