Opened 9 years ago

Closed 9 years ago

#2026 closed defect (fixed)

ARM exits immediatly after launch

Reported by: tomb Owned by: atagar
Priority: Medium Milestone:
Component: Core Tor/Nyx Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I have just installed arm for the first time on my relay. When I run it it immediately exits with the output included in the attachment. I am using no armrc.

Vital statistics:
[root@heydt-benjamin ~]# uname -a
Linux heydt-benjamin.com 2.6.9-023stab048.6-enterprise #1 SMP Mon Nov 17 19:09:18 MSK 2008 i686 i686 i386 GNU/Linux

[root@heydt-benjamin ~]# tor --version
Oct 08 07:55:58.467 [notice] Tor v0.2.2.17-alpha (git-a3f488a88773225a). This is experimental software. Do not rely on it for strong anonymity. (Running on Linux i686)
Tor version 0.2.2.17-alpha (git-a3f488a88773225a).

[root@heydt-benjamin ~]# python --version
Python 2.7

[root@heydt-benjamin ~]# arm --version
arm version 1.3.7 (released October 6, 2010)

Child Tickets

Attachments (2)

screenlog.0 (4.9 KB) - added by tomb 9 years ago.
Log of output leading to abnormal exit
armTraceback (398 bytes) - added by tomb 9 years ago.
Traceback file from same execution as previously attached screen log

Download all attachments as: .zip

Change History (4)

Changed 9 years ago by tomb

Attachment: screenlog.0 added

Log of output leading to abnormal exit

comment:1 Changed 9 years ago by atagar

Thanks tomb! Unfortunately the useful traceback is in '/tmp/armTraceback', would you mind providing that? This is being caused by an exception when redrawing the display and dumping to a file to avoid screwing up the terminal.

Changed 9 years ago by tomb

Attachment: armTraceback added

Traceback file from same execution as previously attached screen log

comment:2 Changed 9 years ago by atagar

Resolution: fixed
Status: newclosed

Fix checked in and now rebuilding releases. Thanks tomb for the catch!

Note: See TracTickets for help on using tickets.