Opened 3 years ago

Closed 2 years ago

#20267 closed defect (worksforme)

Use -DOPENSSL_SYS_WIN32 on Windows

Reported by: teor Owned by:
Priority: Medium Milestone: Tor: 0.3.1.x-final
Component: Core Tor/Tor Version:
Severity: Normal Keywords: regression, windows, nickm-deferred-20161017, triage-out-030-201612
Cc: Actual Points:
Parent ID: Points: 0.1
Reviewer: Sponsor:

Description

Tor fails to compile on Windows MinGW/msys with an error about X509_NAME being an integer literal.

This is because OPENSSL_SYS_WIN32 is not defined, but it should be.

When we are on Win32, we should define this preprocessor directive.

Child Tickets

Change History (7)

comment:1 Changed 3 years ago by nickm

That's weird. I thought that OpenSSL was supposed to define this for us.

comment:2 in reply to:  1 Changed 3 years ago by teor

Replying to nickm:

That's weird. I thought that OpenSSL was supposed to define this for us.

Not OpenSSL 1.0.0 on msys (1.0). Perhaps using a later version would help.

comment:3 Changed 3 years ago by nickm

Huh. It's supposed to be defined in include/openssl/e_os2.h . Maybe they messed it up.

comment:4 Changed 3 years ago by nickm

Status: newneeds_information

Since we dropped OpenSSL 1.0.0 support, is this still an issue (with >=1.0.1)?

comment:5 Changed 3 years ago by nickm

Keywords: nickm-deferred-20161017 added
Milestone: Tor: 0.2.9.x-finalTor: 0.3.0.x-final

I am fairly sure that these are neither regressions nor major problems. So, deferring from 0.2.9. Please let me know if I'm wrong.

comment:6 Changed 3 years ago by dgoulet

Keywords: triage-out-030-201612 added
Milestone: Tor: 0.3.0.x-finalTor: 0.3.1.x-final

Triaged out on December 2016 from 030 to 031.

comment:7 Changed 2 years ago by nickm

Resolution: worksforme
Status: needs_informationclosed

Please reopen if this is a problem with current tor and current openssl?

Note: See TracTickets for help on using tickets.