Opened 3 years ago

Closed 3 years ago

#20297 closed defect (wontfix)

OTR query messages with|without HTML formatting

Reported by: lnl Owned by:
Priority: Low Milestone:
Component: Archived/Tor Messenger Version:
Severity: Minor Keywords:
Cc: arlolra, sukhbir Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I'm using Tor Messenger 0.2.0b2 on macOS Sierra 10.12.

I've gotten the same error, but sometimes, it displays as:

"<redacted> has requested an Off-the Record private conversation. However, you do not have a plugin to support that. See http://otr.cypherpunks.ca/ for more information."

And other times, it displays as (I see the HTML formatting as plaintext):

"<b><redacted></b> has requested an <a href="https://otr.cypherpunks.ca/">Off-the-Record private conversation</a>. However, you do not have a plugin to support that.
See <a href="https://otr.cypherpunks.ca/">https://otr.cypherpunks.ca/</a>; for more information."

Child Tickets

Attachments (1)

tor-messenger-otr-error.png (161.0 KB) - added by lnl 3 years ago.

Download all attachments as: .zip

Change History (8)

Changed 3 years ago by lnl

Attachment: tor-messenger-otr-error.png added

comment:1 Changed 3 years ago by sukhbir

Cc: sukhbir added

comment:2 Changed 3 years ago by sukhbir

Related: #20298.

(I can't reproduce this on sierra, but since there is no OTR menu I am guessing the issue lies there).

comment:3 Changed 3 years ago by arlolra

Thanks for reporting!

See the commit msg here, https://github.com/arlolra/ctypes-otr/commit/26d384d8407c2fd5ad3797fad5f599ae28acb4b4

The dead link to https://bugs.otr.im/issues/79 is now https://bugs.otr.im/lib/libotr/issues/79
I'm not sure where my patch disappeared to there, but there used to be a fix that was awaiting review. I could maybe just apply it to the libotr.so we're shipping, but I'd rather wait on them to give it the ok.

Basically, the one that doesn't have formatting is from when arma manually triggered the query message to start the conversation.

The second one, with the formatting, is the one that libotr send automatically when you type a message before the OTR session is started, and encrypting is enforced.

comment:4 Changed 3 years ago by arlolra

Ps. the reason you're seeing these at all, is because of #20298 where we find out the ctypes-otr isn't enabled for you for some reason.

comment:5 in reply to:  4 Changed 3 years ago by sukhbir

Replying to arlolra:

Ps. the reason you're seeing these at all, is because of #20298 where we find out the ctypes-otr isn't enabled for you for some reason.

Yeah so I am guessing it's related more to that than to comment:3.

comment:6 Changed 3 years ago by arlolra

Priority: MediumLow
Summary: Tor Messenger: error messages with|without HTML formattingOTR query messages with|without HTML formatting

comment:7 Changed 3 years ago by lnl

Resolution: wontfix
Status: newclosed
Note: See TracTickets for help on using tickets.