Opened 3 years ago

Closed 3 years ago

#20299 closed defect (worksforme)

Tried to update now tor wont start

Reported by: lfresh Owned by:
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: mcs, brade Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

this is the error message:

Tor exited during startup. This might be due to an error in your torrc file, a bug in Tor or another program on your system, or faulty hardware. Until you fix the underlying problem and restart Tor, Tor Browser will not start.

there are 0 tor logs to show unfortunately and i have no idea what the problem is. i've tossed the old brpawser tried to download a new one
still stuck

Child Tickets

Change History (6)

comment:1 Changed 3 years ago by gk

Component: - Select a componentApplications/Tor Browser
Status: newneeds_information

From which to which version did you update? What operating system are you on?

comment:2 Changed 3 years ago by lfresh

Unfortunately i'm not certain what the previous version was i downloaded in July if that helps.

I use OS El Capitan

comment:3 in reply to:  2 Changed 3 years ago by gk

Cc: mcs brade added

Replying to lfresh:

Unfortunately i'm not certain what the previous version was i downloaded in July if that helps.

I use OS El Capitan

Where do you have Tor Browser installed? In your /Applications directory? If so can you make a copy of your TorBrowser-Data folder (you can find it with the help shown in comment:8:ticket:20300) for further inspection/bookmark backups? If you have done so, removing that folder while Tor Browser is shut down and restarting it might solve your issue. It would probably be super helpful if you could follow the steps in comment:11:ticket:20300 and report that output back. We see at a glance what is wrong with your Tor Browser then.

comment:4 Changed 3 years ago by halopez

The error persists, and I have some additional debugging information, following gk's suggestions.

The output log after having activated logging is the following:

TorBrowser-Data HULO$ /Applications/TorBrowser.app/Contents/MacOS/firefox
[10-18 12:38:30] TorLauncher INFO: debug output ready
[10-18 12:38:30] TorLauncher DBUG: Starting /Applications/TorBrowser.app/Contents/Resources/TorBrowser/Tor/tor
[10-18 12:38:30] TorLauncher DBUG:   --defaults-torrc
[10-18 12:38:30] TorLauncher DBUG:   /Applications/TorBrowser.app/Contents/Resources/TorBrowser/Tor/torrc-defaults
[10-18 12:38:30] TorLauncher DBUG:   -f
[10-18 12:38:30] TorLauncher DBUG:   /Users/HULO/Library/Application Support/TorBrowser-Data/Tor/torrc
[10-18 12:38:30] TorLauncher DBUG:   DataDirectory
[10-18 12:38:30] TorLauncher DBUG:   /Users/HULO/Library/Application Support/TorBrowser-Data/Tor
[10-18 12:38:30] TorLauncher DBUG:   GeoIPFile
[10-18 12:38:30] TorLauncher DBUG:   /Applications/TorBrowser.app/Contents/Resources/TorBrowser/Tor/geoip
[10-18 12:38:30] TorLauncher DBUG:   GeoIPv6File
[10-18 12:38:30] TorLauncher DBUG:   /Applications/TorBrowser.app/Contents/Resources/TorBrowser/Tor/geoip6
[10-18 12:38:30] TorLauncher DBUG:   HashedControlPassword
[10-18 12:38:30] TorLauncher DBUG:   16:779618a21237cc4060c538e1c90dabce2fdfca71e74b8c14879353ee63
[10-18 12:38:30] TorLauncher DBUG:   __OwningControllerProcess
[10-18 12:38:30] TorLauncher DBUG:   85056
Oct 18 14:38:30.581 [notice] Tor v0.2.8.7 (git-263088633a63982a) running on Darwin with Libevent 2.0.22-stable, OpenSSL 1.0.1t and Zlib 1.2.5.
Oct 18 14:38:30.582 [notice] Tor can't help you if you use it wrong! Learn how to be safe at https://www.torproject.org/download/download#warning
Oct 18 14:38:30.582 [notice] Read configuration file "/Applications/TorBrowser.app/Contents/Resources/TorBrowser/Tor/torrc-defaults".
Oct 18 14:38:30.582 [notice] Read configuration file "/Users/HULO/Library/Application Support/TorBrowser-Data/Tor/torrc".
Oct 18 14:38:30.586 [notice] Opening Socks listener on 127.0.0.1:9150
Oct 18 14:38:30.586 [warn] Could not bind to 127.0.0.1:9150: Address already in use. Is Tor already running?
Oct 18 14:38:30.586 [notice] Opening Control listener on 127.0.0.1:9151
Oct 18 14:38:30.586 [warn] Could not bind to 127.0.0.1:9151: Address already in use. Is Tor already running?
Oct 18 14:38:30.586 [warn] Failed to parse/validate config: Failed to bind one of the listener ports.
Oct 18 14:38:30.586 [err] Reading config failed--see warnings above.
[10-18 12:38:30] TorLauncher DBUG: Opening control connection to 127.0.0.1:9151
[10-18 12:38:30] TorLauncher DBUG: Sending Tor command: AUTHENTICATE XXXX (removed intentionally)
[10-18 12:38:30] TorLauncher DBUG: Command response: 515 Authentication failed: Password did not match HashedControlPassword *or* authentication cookie.
[10-18 12:38:30] TorLauncher NOTE: authenticate failed
[10-18 12:38:30] TorLauncher NOTE: Tor exited during startup. This might be due to an error in your torrc file, a bug in Tor or another program on your system, or faulty hardware. Until you fix the underlying problem and restart Tor, Tor Browser will not start.
[10-18 12:38:44] TorLauncher DBUG: Starting /Applications/TorBrowser.app/Contents/Resources/TorBrowser/Tor/tor
[10-18 12:38:44] TorLauncher DBUG:   --defaults-torrc
[10-18 12:38:44] TorLauncher DBUG:   /Applications/TorBrowser.app/Contents/Resources/TorBrowser/Tor/torrc-defaults
[10-18 12:38:44] TorLauncher DBUG:   -f
[10-18 12:38:44] TorLauncher DBUG:   /Users/HULO/Library/Application Support/TorBrowser-Data/Tor/torrc
[10-18 12:38:44] TorLauncher DBUG:   DataDirectory
[10-18 12:38:44] TorLauncher DBUG:   /Users/HULO/Library/Application Support/TorBrowser-Data/Tor
[10-18 12:38:44] TorLauncher DBUG:   GeoIPFile
[10-18 12:38:44] TorLauncher DBUG:   /Applications/TorBrowser.app/Contents/Resources/TorBrowser/Tor/geoip
[10-18 12:38:44] TorLauncher DBUG:   GeoIPv6File
[10-18 12:38:44] TorLauncher DBUG:   /Applications/TorBrowser.app/Contents/Resources/TorBrowser/Tor/geoip6
[10-18 12:38:44] TorLauncher DBUG:   HashedControlPassword
[10-18 12:38:44] TorLauncher DBUG:   16:168981f1b60a28d16021760fbcfda74d56206aeac7aa840eb620fbbf83
[10-18 12:38:44] TorLauncher DBUG:   __OwningControllerProcess
[10-18 12:38:44] TorLauncher DBUG:   85056
[10-18 12:38:44] TorLauncher DBUG: Opening control connection to 127.0.0.1:9151
[10-18 12:38:44] TorLauncher DBUG: Sending Tor command: AUTHENTICATE XXXX (removed intentionally)
[10-18 12:38:44] TorLauncher DBUG: Command response: 515 Authentication failed: Password did not match HashedControlPassword *or* authentication cookie.
[10-18 12:38:44] TorLauncher NOTE: authenticate failed
Oct 18 14:38:44.136 [notice] Tor v0.2.8.7 (git-263088633a63982a) running on Darwin with Libevent 2.0.22-stable, OpenSSL 1.0.1t and Zlib 1.2.5.
Oct 18 14:38:44.137 [notice] Tor can't help you if you use it wrong! Learn how to be safe at https://www.torproject.org/download/download#warning
Oct 18 14:38:44.137 [notice] Read configuration file "/Applications/TorBrowser.app/Contents/Resources/TorBrowser/Tor/torrc-defaults".
Oct 18 14:38:44.137 [notice] Read configuration file "/Users/HULO/Library/Application Support/TorBrowser-Data/Tor/torrc".
Oct 18 14:38:44.142 [notice] Opening Socks listener on 127.0.0.1:9150
Oct 18 14:38:44.142 [warn] Could not bind to 127.0.0.1:9150: Address already in use. Is Tor already running?
Oct 18 14:38:44.142 [notice] Opening Control listener on 127.0.0.1:9151
Oct 18 14:38:44.142 [warn] Could not bind to 127.0.0.1:9151: Address already in use. Is Tor already running?
Oct 18 14:38:44.142 [warn] Failed to parse/validate config: Failed to bind one of the listener ports.
Oct 18 14:38:44.142 [err] Reading config failed--see warnings above.
[10-18 12:38:44] TorLauncher NOTE: Tor exited during startup. This might be due to an error in your torrc file, a bug in Tor or another program on your system, or faulty hardware. Until you fix the underlying problem and restart Tor, Tor Browser will not start.
[10-18 12:38:46] TorLauncher DBUG: initDialog done


[10-18 12:38:53] TorLauncher DBUG: initDialog done

I'm running Mac OS 10.10.5.

The case looks similar to ticket #18947, in the sense that, if run outside the Applications folder on a clean TorBrowser-Data folder, things seem to work. I guess it must have been a migration error, but I cannot spot how to correct it. Any suggestions?

Last edited 3 years ago by halopez (previous) (diff)

comment:5 Changed 3 years ago by teor

Status: needs_informationnew

It seems you have more than one tor process running at the same time.

Oct 18 14:38:44.137 [notice] Read configuration file "/Users/HULO/Library/Application Support/TorBrowser-Data/Tor/torrc".
Oct 18 14:38:44.142 [notice] Opening Socks listener on 127.0.0.1:9150
Oct 18 14:38:44.142 [warn] Could not bind to 127.0.0.1:9150: Address already in use. Is Tor already running?
Oct 18 14:38:44.142 [notice] Opening Control listener on 127.0.0.1:9151
Oct 18 14:38:44.142 [warn] Could not bind to 127.0.0.1:9151: Address already in use. Is Tor already running?
Oct 18 14:38:44.142 [warn] Failed to parse/validate config: Failed to bind one of the listener ports.

comment:6 Changed 3 years ago by gk

Resolution: worksforme
Status: newclosed

lfresh: it seems you need to get rid of your TorBrowser-Data directory and then it should work again. See comment:24:ticket:13252 for where to look on your machine.

Note: See TracTickets for help on using tickets.