Opened 3 years ago

Closed 3 years ago

#20306 closed defect (fixed)

"Tor cannot connect to the Internet if ReachableAddresses, ReachableORAddresses, or ReachableDirAddresses reject all addresses. Please accept some addresses in these options." when "FascistFirewall 1" is set

Reported by: arma Owned by:
Priority: Medium Milestone: Tor: 0.2.9.x-final
Component: Core Tor/Tor Version: Tor: 0.2.9.3-alpha
Severity: Normal Keywords: regression nickm-deferred-20161017
Cc: teor Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I start my Tor client running 0.2.9.3-alpha-dev (git-bfaded9143d127cb) with FascistFirewall 1, and it says:

Oct 06 15:32:11.620 [notice] Converting FascistFirewall config option to new format: "ReachableDirAddresses *:80"
Oct 06 15:32:11.620 [notice] Converting FascistFirewall config option to new format: "ReachableORAddresses *:443"

which is reasonable, but later it says

Oct 06 15:32:11.623 [warn] Tor cannot connect to the Internet if ReachableAddresses, ReachableORAddresses, or ReachableDirAddresses reject all addresses. Please accept some addresses in these options.

which is surprising.

Child Tickets

Change History (7)

comment:1 Changed 3 years ago by nickm

Looks like this bug also exists in 0.2.8.

comment:2 Changed 3 years ago by nickm

Cc: teor added

Here's what git bisect says:

There are only 'skip'ped commits left to test.
The first bad commit could be any of:
268608c0a0605e596d1a884ee35d432c88bac38b
2d33d192fc4dd0da2a2e038dd87b277f8e9b90de
e72cbf7a4e346f0d379961520db8bea7e9249f88
We cannot bisect more!

I think I blame 2d33d192fc4dd0da2a2e038dd87b277f8e9b90de, since that's the one that introduces the warning in the first place.

comment:3 Changed 3 years ago by nickm

Keywords: nickm-deferred-20161017 added

This is annoying, but not a regression in 0.2.9. Deferring to 0.3.0.

comment:4 Changed 3 years ago by teor

It looks like this check confuses reject *:80 and reject *:*. This may mean that we need to revise the is_reject_star code, or the code that uses it.

comment:5 Changed 3 years ago by nickm

Status: newneeds_review

It looks like this check confuses reject *:80 and reject *:*. This may mean that we need to revise the is_reject_star code, or the code that uses it.

I think the problem there might be that policy_is_reject_star() doesn't know about how some policies have different defaults on unmatched addresses than others. How about this? bug20306_029

comment:6 Changed 3 years ago by teor

Status: needs_reviewmerge_ready

Seems plausible to me.

comment:7 Changed 3 years ago by nickm

Resolution: fixed
Status: merge_readyclosed

Thanks; merged it!

Note: See TracTickets for help on using tickets.