Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#20330 closed defect (worksforme)

Tor browser no longer starts in OSX

Reported by: redacted Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: mcs, brade Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Hi

Tor browser won't start since yesterday. I get the Tor Status "Please wait while we establish a connection..." for some time, then a pop-up telling me "Could not connect to Tor control port"

I've tried removing Tor and downloading the latest version (no change).
My clock is correct.

Oct 09 18:29:44.754 [notice] Tor v0.2.8.7 (git-263088633a63982a) running on Darwin with Libevent 2.0.22-stable, OpenSSL 1.0.1t and Zlib 1.2.5.
Oct 09 18:29:44.761 [notice] Tor can't help you if you use it wrong! Learn how to be safe at https://www.torproject.org/download/download#warning
Oct 09 18:29:44.762 [notice] Read configuration file "/Applications/TorBrowser.app/Contents/Resources/TorBrowser/Tor/torrc-defaults".
Oct 09 18:29:44.765 [notice] Read configuration file "/Users/Redacted/Library/Application Support/TorBrowser-Data/Tor/torrc".
Oct 09 18:29:44.773 [warn] Unrecognized ControlPort option '"Support/TorBrowser-Data/Tor/control.socket"'
Oct 09 18:29:44.850 [warn] Unrecognized ControlPort option '"Support/TorBrowser-Data/Tor/control.socket"'
Oct 09 18:29:44.850 [notice] Opening Control listener on /Users/Rory/Library/Application
Oct 09 18:29:44.851 [notice] DisableNetwork is set. Tor will not make or accept non-control network connections. Shutting down all existing connections.
Oct 09 18:29:44.000 [notice] Parsing GEOIP IPv4 file /Applications/TorBrowser.app/Contents/Resources/TorBrowser/Tor/geoip.
Oct 09 18:29:45.000 [notice] Parsing GEOIP IPv6 file /Applications/TorBrowser.app/Contents/Resources/TorBrowser/Tor/geoip6.
Oct 09 18:29:45.000 [notice] Bootstrapped 0%: Starting
Oct 09 18:29:46.000 [notice] Delaying directory fetches: DisableNetwork is set.

Child Tickets

Change History (5)

comment:1 Changed 3 years ago by redacted

Component: - Select a componentApplications/Tor Browser
Owner: set to tbb-team

comment:2 Changed 3 years ago by gk

Cc: mcs brade added
Status: newneeds_information

What happened since yesterday? Did you try out an alpha version in the meantime?

Oct 09 18:29:44.773 [warn] Unrecognized ControlPort option '"Support/TorBrowser-Data/Tor/control.socket"'
Oct 09 18:29:44.850 [warn] Unrecognized ControlPort option '"Support/TorBrowser-Data/Tor/control.socket"'

are indicating that you have a TorLauncher that we only ship in the alpha series in your profile. Could you make a copy of your TorBrowser-Data directory (the one in /Users/Redacted/Library/Application Support for further inspection and as a backup for you? Deleting that directory while having Tor Browser closed and restarting it should fix your issue.

Still it would be neat to understand what is going on as we seem to have a bunch of users being affected by that.

comment:3 in reply to:  2 Changed 3 years ago by redacted

Replying to gk:

What happened since yesterday? Did you try out an alpha version in the meantime?

Oct 09 18:29:44.773 [warn] Unrecognized ControlPort option '"Support/TorBrowser-Data/Tor/control.socket"'
Oct 09 18:29:44.850 [warn] Unrecognized ControlPort option '"Support/TorBrowser-Data/Tor/control.socket"'

are indicating that you have a TorLauncher that we only ship in the alpha series in your profile. Could you make a copy of your TorBrowser-Data directory (the one in /Users/Redacted/Library/Application Support for further inspection and as a backup for you? Deleting that directory while having Tor Browser closed and restarting it should fix your issue.

Still it would be neat to understand what is going on as we seem to have a bunch of users being affected by that.

Hi, thanks for the reply.
Yesterday was the first time I'd tried to use Tor in over a week and I'm not aware of installing an alpha release; however I do seem to recall that the last time it was working it downloaded an update (which I opted to install after ending my session).
Before reading your reply I removed Tor again but this time also manually deleting files related to Tor under
/Users/Redacted/Library/Application Support/
/Users/Redacted/Library/Caches/
/Users/Redacted/Library/Preferences/
...then installing again. It now works so I'm afraid I don't have the files for you to analyse (sorry), but if it happens again I'll be sure to come back with copies.

comment:4 Changed 3 years ago by gk

Resolution: worksforme
Status: needs_informationclosed

Okay, thanks for your help. Which locale are you using (maybe that is a clue that could help us further debugging the problem)?

comment:5 Changed 3 years ago by mcs

Kathy and I looked at the 6.0.5 dmg files, incremental MAR files, and complete MAR files for two locales (en-US and es-ES). None of the files include the wrong Tor Launcher; that is, none of them include a Tor Launcher that has control port socket support.

It seems like the alpha TB must have been opened at some point, although our users say otherwise. Strange.

Note: See TracTickets for help on using tickets.