Changes between Version 1 and Version 2 of Ticket #20352, comment 3


Ignore:
Timestamp:
Nov 20, 2016, 2:53:13 AM (4 years ago)
Author:
yawning
Comment:

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #20352, comment 3

    v1 v2  
    33 * libx11-dev (The calls I use have always been there, and always will).
    44 * Gtk+ 3.14 - Build assumes this, see the Makefile.
    5  * libseccomp2 (2.2.1, 2.2.3 in backports).
     5 * libseccomp2 (2.1.1, 2.2.3 in backports).
    66
    7 ~~~The libseccomp bindings I use determine the version of the library at compile time, so if we build against 2.2.1, we will be stuck with the features supported by it.  This degrades the effectiveness of the seccomp filters I use somewhat because conditional rules do not work correctly prior to 2.2.2.~~~ (Edit: This is probably fine, upon close examination, needs testing.)
     7~~~The libseccomp bindings I use determine the version of the library at compile time, so if we build against 2.1.1, we will be stuck with the features supported by it.  This degrades the effectiveness of the seccomp filters I use somewhat because conditional rules do not work correctly prior to 2.2.1.~~~ (Edit: This is probably fine, upon close examination, needs testing.)
    88
    99(Someone should double check that `sandboxed-tor-browser` built against ancient libs works even if more modern versions are installed, even if it isn't as good as it can be.)