Opened 3 years ago

Closed 3 years ago

#20418 closed defect (duplicate)

Assertion anonymized_connection rend_non_anonymous_mode_enabled(options) failed in directory_initiate_command_rend

Reported by: Ricky_Martin Owned by:
Priority: Medium Milestone: Tor: 0.3.0.x-final
Component: Core Tor/Tor Version: Tor: 0.3.0.0-alpha-dev
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Oct 20 22:10:08.000 [notice] Bootstrapped 85%: Finishing handshake with first hop

Oct 20 22:10:09.000 [err] tor_assertion_failed_(): Bug: ../src/or/directory.c:1147: directory_initiate_command_rend: Assertion anonymized_connection Oct 20 22:10:09.000 [err] Bug: Assertion anonymized_connection
rend_non_anonymous_mode_enabled(options) failed; aborting. (on Tor 0.3.0.0-alpha-dev )
rend_non_anonymous_mode_enabled(options) failed in directory_initiate_command_rend at ../src/or/directory.c:1147. Stack trace: (on Tor 0.3.0.0-alpha-dev )

Oct 20 22:10:09.000 [err] Bug: /usr/bin/tor(log_backtrace+0x42) [0x55fcec336be2] (on Tor 0.3.0.0-alpha-dev )
Oct 20 22:10:09.000 [err] Bug: /usr/bin/tor(tor_assertion_failed_+0x8d) [0x55fcec34f3ad] (on Tor 0.3.0.0-alpha-dev )
Oct 20 22:10:09.000 [err] Bug: /usr/bin/tor(+0x1179a9) [0x55fcec3039a9] (on Tor 0.3.0.0-alpha-dev )
Oct 20 22:10:09.000 [err] Bug: /usr/bin/tor(directory_initiate_command+0x111) [0x55fcec3045f1] (on Tor 0.3.0.0-alpha-dev )
Oct 20 22:10:09.000 [err] Bug: /usr/bin/tor(+0x13ac07) [0x55fcec326c07] (on Tor 0.3.0.0-alpha-dev )
Oct 20 22:10:09.000 [err] Bug: /usr/bin/tor(fetch_bridge_descriptors+0x2d8) [0x55fcec32bd78] (on Tor 0.3.0.0-alpha-dev )
Oct 20 22:10:09.000 [err] Bug: /usr/bin/tor(+0x4288b) [0x55fcec22e88b] (on Tor 0.3.0.0-alpha-dev )
Oct 20 22:10:09.000 [err] Bug: /usr/lib/x86_64-linux-gnu/libevent-2.0.so.5(event_base_loop+0x7fc) [0x7f3666bbda0c] (on Tor 0.3.0.0-alpha-dev )
Oct 20 22:10:09.000 [err] Bug: /usr/bin/tor(do_main_loop+0x285) [0x55fcec22f405] (on Tor 0.3.0.0-alpha-dev )
Oct 20 22:10:09.000 [err] Bug: /usr/bin/tor(tor_main+0x1c35) [0x55fcec232dc5] (on Tor 0.3.0.0-alpha-dev )
Oct 20 22:10:09.000 [err] Bug: /usr/bin/tor(main+0x19) [0x55fcec22ae39] (on Tor 0.3.0.0-alpha-dev )
Oct 20 22:10:09.000 [err] Bug: /lib/x86_64-linux-gnu/libc.so.6(libc_start_main+0xf0) [0x7f3665cf8830] (on Tor 0.3.0.0-alpha-dev )
Oct 20 22:10:09.000 [err] Bug: /usr/bin/tor(_start+0x29) [0x55fcec22ae89] (on Tor 0.3.0.0-alpha-dev )
Oct 20 22:10:09.000 [notice] Tor 0.3.0.0-alpha-dev (git-d1bcba19a9790a37+e6e941b) opening log file.
Oct 20 22:10:09.667 [notice] Tor 0.3.0.0-alpha-dev (git-d1bcba19a9790a37+e6e941b) running on Linux with Libevent 2.0.21-stable, OpenSSL 1.0.2g and Zlib 1.2.8.
Oct 20 22:10:09.667 [notice] Tor can't help you if you use it wrong! Learn how to be safe at https://www.torproject.org/download/download#warning
Oct 20 22:10:09.667 [notice] This version is not a stable Tor release. Expect more bugs than usual.

Child Tickets

Change History (1)

comment:1 Changed 3 years ago by dgoulet

Resolution: duplicate
Status: newclosed

Duplicate of #20410

Note: See TracTickets for help on using tickets.