Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#20427 closed defect (worksforme)

Could not connect to TOR Control Port

Reported by: Dad Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: mcs, brade Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I have found that when I install Tor to default location (Desktop) in Windows 8.1 pro x64 it works fine, but when I install it to another folder, for example, C:\Program_Files I got the error "Could not connect to TOR Control Port".
Why so and how to avoid this?

Child Tickets

Change History (15)

comment:1 Changed 3 years ago by gk

Cc: mcs brade added
Component: - Select a componentApplications/Tor Browser
Status: newneeds_information

Which Tor Browser version are you using?

comment:2 Changed 3 years ago by gk

Owner: set to tbb-team
Status: needs_informationassigned

comment:3 Changed 3 years ago by gk

Status: assignedneeds_information

comment:4 Changed 3 years ago by Dad

Latest - 6.0.5, downloaded at the day of installation (2016-10-21)

comment:5 Changed 3 years ago by gk

Hm. This works for me with a fresh 6.0.5. Do you see a button "Copy Tor log to Clipboard" you could press and which would maybe give you and us some useful information?

comment:6 Changed 3 years ago by Dad

"0 Tor log messages are ready to be pasted..." 
see picture: http://s020.radikal.ru/i722/1610/b4/4719f9f132dc.jpg

comment:7 Changed 3 years ago by mcs

I assume you are starting completely fresh, i.e., you are not installing on top of an existing location?

Since Tor Launcher is not capturing any log messages, you will need to configure the tor process so that it logs to a file:

  1. Edit c:\Program Files\Tor Browser\Browser\TorBrowser\Data\Tor\torrc using a text editor and add the line: Log debug file c:\torlog.txt.
  2. Start Tor Browser and see if anything is logged to that file.

It is possible that some anti-virus/anti-malware software on your computer is interfering with the browser/tor communication when it is installed under c:\Program Files (although I do not know why it would allow communication when Tor Browser is installed on the desktop).

It is also possible that tor.exe is not being allowed to start at all. You might look and see whether a tor.exe process is running or not (e.g., using Task Manager or Process Explorer). One tor.exe process should be present while Tor Browser (firefox.exe) is running and it should disappear only when you close Tor Browser.

comment:8 Changed 3 years ago by Dad

  1. yes, it's completely fresh

1-2 still empty log, tor.exe is running - see picture http://s018.radikal.ru/i512/1610/17/5dabd619927d.jpg

  1. read carefully, my tor in question not in "c:\Program Files\" but in "c:\Program_Files\" :-)

comment:9 Changed 3 years ago by gk

Weird that you are not getting any debug output. Let's try it a bit differently. Could you download the standalone bundle:

https://dist.torproject.org/torbrowser/6.0.5/tor-win32-0.2.8.7.zip
https://dist.torproject.org/torbrowser/6.0.5/tor-win32-0.2.8.7.zip.asc

and copy the tor.exe from there over the one in your Tor Browser? The latter is located in path\to\Tor Browser\Browser\TorBrowser\Tor.

If you now start Tor Browser you should see minimal debug output (like that Tor gets started etc.) in a console window popping up. Could you give us that log? Maybe we can spot the issue already there. You can try the thing that mcs said above (adjusting your paths, of course) and add the log line:
Log debug stdout which should give you lots of output in the console window (in fact it might give you too much but I am not sure). If that works there is something else that went wrong while using tor's logging capabilities which we then can sort out.

Thanks for your patience and help.

comment:10 Changed 3 years ago by Dad

Here it is - http://s019.radikal.ru/i616/1610/b4/641546bc7a7f.jpg

But I did more, I start your tor from working configuration and found strange thing

  • at first start I got also "could not connect" with console windows full of log messages (unfortunately have not saved screenshot)

I use DrWeb antivirus and firewall

comment:11 in reply to:  10 Changed 3 years ago by mcs

Replying to Dad:

Here it is - http://s019.radikal.ru/i616/1610/b4/641546bc7a7f.jpg

But I did more, I start your tor from working configuration and found strange thing

  • at first start I got also "could not connect" with console windows full of log messages (unfortunately have not saved screenshot)

I use DrWeb antivirus and firewall

I am not very familiar with libevent (used by the tor daemon), but the warning message that was logged looks interesting. It seems to indicate that use of local TCP sockets may be blocked (but maybe that message is not important; I do not know). Is there any chance you can temporarily disable your AV/firewall software and then try starting Tor Browser?

comment:12 Changed 3 years ago by Dad

Hmm, very strange! With Av disabled tor starts but with very same log messages ("disable network is set ...") - http://s017.radikal.ru/i422/1610/d7/0f2b586de5e2.jpg 

comment:13 Changed 3 years ago by mcs

If Tor Browser is starting correctly when your AV is disabled, then interference from the AV software must be the cause of the problem described by this ticket. "DisableNetwork is set" is a normal thing to see in the tor output when Tor Browser is opened for the first time (networking will be enabled after the initial Tor configuration has been completed).

comment:14 Changed 3 years ago by gk

Resolution: worksforme
Status: needs_informationclosed

I agree. This does not seem to be a Tor Browser issue then.

comment:15 Changed 3 years ago by bugzilla

It's a variant of what bugzilla warned you about in #19957.
What about creating meta ticket for AV/FW/techsupp issues?

Note: See TracTickets for help on using tickets.