Opened 3 years ago

Closed 22 months ago

#20474 closed defect (duplicate)

Tor should try harder to choose nodes in small networks

Reported by: teor Owned by:
Priority: Low Milestone: Tor: unspecified
Component: Core Tor/Tor Version:
Severity: Normal Keywords: easy, small-network, tor-client testing
Cc: Actual Points:
Parent ID: #24169 Points: 1
Reviewer: Sponsor:

Description

In https://trac.torproject.org/projects/tor/ticket/14881#comment:58 , pastly reports that in networks without bandwidth weights, tor says:

Oct 26 19:56:00.000 [warn] Failed to find node for hop 1 of our path. Discarding this circuit.

We should fix this at some point by falling back to choosing a random node.

Child Tickets

Change History (5)

comment:1 Changed 3 years ago by teor

Milestone: Tor: 0.2.???Tor: 0.3.???

Milestone renamed

comment:2 Changed 3 years ago by nickm

Keywords: tor-03-unspecified-201612 added
Milestone: Tor: 0.3.???Tor: unspecified

Finally admitting that 0.3.??? was a euphemism for Tor: unspecified all along.

comment:3 Changed 3 years ago by nickm

Keywords: tor-03-unspecified-201612 removed

Remove an old triaging keyword.

comment:4 Changed 3 years ago by nickm

Keywords: small-network tor-client testing added
Priority: MediumLow

comment:5 Changed 22 months ago by teor

Parent ID: #24169
Resolution: duplicate
Status: newclosed

We either fixed this in #23318, or it is a duplicate of #24169

Note: See TracTickets for help on using tickets.