Opened 3 years ago

Closed 3 years ago

#20494 closed defect (fixed)

connection_ap_handshake_rewrite_and_attach: This line should not have been reached

Reported by: mcs Owned by:
Priority: Medium Milestone: Tor: 0.3.0.x-final
Component: Core Tor/Tor Version: Tor: 0.3.0.0-alpha-dev
Severity: Normal Keywords: tbb-needs
Cc: Actual Points: 0
Parent ID: Points:
Reviewer: Sponsor:

Description

I encountered the following when testing my own OSX tor build with Tor Browser:

Oct 28 10:38:31.000 [warn] tor_bug_occurred_: Bug: src/or/connection_edge.c:1593: connection_ap_handshake_rewrite_and_attach: This line should not have been reached. (Future instances of this warning will be silenced.) (on Tor 0.3.0.0-alpha-dev f3e158edf7d8128d)

(see ticket:20261 for a similar issue)

Child Tickets

Attachments (1)

stack2.txt (3.4 KB) - added by mcs 3 years ago.
logged stack trace

Download all attachments as: .zip

Change History (6)

Changed 3 years ago by mcs

Attachment: stack2.txt added

logged stack trace

comment:1 Changed 3 years ago by nickm

Ha, that's totally my fault.

I added it in f3e158edf7d8128, because the code used to say:

-    /* No else, we've covered all possible returned value. */

Looks like that wasn't true in the sense I had thought.

comment:2 Changed 3 years ago by nickm

Actual Points: 0
Milestone: Tor: 0.3.0.x-final
Status: newneeds_review

Branch bug20494 in my public repository has a fix here; somebody should have a quick look, though.

comment:3 Changed 3 years ago by teor

Status: needs_reviewmerge_ready

That seems more like it, and does cover all the cases from tor_addr_parse.

comment:4 Changed 3 years ago by mcs

I confirmed that this patch fixes the problem for me. I don't understand the tor code and the context well enough to really review the patch, but it seems okay to me.

comment:5 Changed 3 years ago by nickm

Resolution: fixed
Status: merge_readyclosed

Merged to master. thanks for the quick review, and sorry for the error!

Note: See TracTickets for help on using tickets.