Opened 9 years ago

Closed 9 years ago

Last modified 7 years ago

#2050 closed defect (fixed)

Bridge guesses local IP address when testing reachability

Reported by: Sebastian Owned by:
Priority: Medium Milestone:
Component: Core Tor/Tor Version:
Severity: Keywords: tor-relay
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

[notice] Now checking whether ORPort 192.168.178.25:[port] is reachable... (this may take up to 20 minutes -- look for log messages indicating success)

This is of course poor, because it will never be reachable on a local address.

Child Tickets

Change History (9)

comment:1 Changed 9 years ago by Sebastian

Oh, this bug isn't as bad as I first thought. It only happens when PublishServerDescriptor 0 is set.

comment:2 Changed 9 years ago by arma

Milestone: Tor: 0.2.1.x-final

Confirmed on master.

Also confirmed on Tor 0.2.1.26.

This happens because in resolve_my_address() we check

  if (is_internal_IP(ntohl(in.s_addr), 0) &&
      options->_PublishServerDescriptor) {
    /* make sure we're ok with publishing an internal IP */

Once upon a time, this config option was named NoPublish, and we had no notion of bridges.

comment:3 Changed 9 years ago by arma

Status: newneeds_review

See bug2050 in my arma. It's on maint-0.2.1, but should apply (with some futzing) all around.

comment:4 Changed 9 years ago by arma

Whoops, I didn't push it to my arma. I pushed it to maint-0.2.1. :/

Anyway, please review it. It's 0a3835821.

comment:5 Changed 9 years ago by nickm

Seems correct to me.

comment:6 Changed 9 years ago by arma

Resolution: fixed
Status: needs_reviewclosed

Merged (retroactively ;) and now closing.

comment:7 Changed 7 years ago by nickm

Keywords: tor-relay added

comment:8 Changed 7 years ago by nickm

Component: Tor RelayTor

comment:9 Changed 7 years ago by nickm

Milestone: Tor: 0.2.1.x-final

Milestone Tor: 0.2.1.x-final deleted

Note: See TracTickets for help on using tickets.