Opened 10 years ago

Closed 10 years ago

Last modified 8 years ago

#2059 closed defect (fixed)

Rename router_get_by_digest()

Reported by: Sebastian Owned by:
Priority: Medium Milestone:
Component: Core Tor/Tor Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:


router_get_by_digest() should be called router_get_by_id_digest(). We should also wait for nickm's nodes branch to be merged before changing this. There might be other places where we call the identity digest just digest, and we should fix these, too (so we don't confuse people with identity digest vs descriptor digest)

Child Tickets

Change History (3)

comment:1 Changed 10 years ago by Sebastian

Status: newneeds_review

bug2059 in my repo. Or does it need a changelog entry?

comment:2 Changed 10 years ago by nickm

Resolution: fixed
Status: needs_reviewclosed

Looks fine to me. Merged.

comment:3 Changed 8 years ago by nickm

Component: Tor ClientTor
Note: See TracTickets for help on using tickets.