Opened 3 years ago

Closed 18 months ago

#20615 closed defect (not a bug)

Your Guard is failing an extremely large amounts of circuits.

Reported by: bug_bunny Owned by:
Priority: Medium Milestone: Tor: 0.3.3.x-final
Component: Core Tor/Tor Version: Tor: 0.2.8.9
Severity: Normal Keywords: performance
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Hello,
Its been several weeks, I am experiencing some problems with tor.
Few weeks ago I started experiencing some connection drops, highly inconsistent bandwidth.
I use to connect my RDP's through tor but connections are dropping abruptly after every few minutes, speed is also highly fluctuating, I never had this problem before.
Then I decided to look at ARM, and I been seeing these messages over and over again.

*TIME* [WARN] Your Guard ---- ($) is failing an extremely large amounts of circuits.
This could indicate a route manipulation attack, extreme network overload or a bug. Success counts are ---.
Use counts are ---. --- cicuits completed. --- were unusable, --- collapsed and --- timed out. For referrence,
your timeout cutoff is 60 seconds.

*TIME* [WARN] Your Guard ----- ($) is failing a very large amounts of circuits.
Most likely this means The Tor network is overloaded, but it could also mean an attack against you or
potentially the guard itself. Success counts .... etc.

And

circuit_package_rely_cell(): Bug: outgoing reply cell sent from ../src/or/rely.c:701 has n_chan==NULL.
Dropping.

What is this? is this some kind of attack?
I tried researching about same errors, but with no avail.
I am using physical isolation technique through virtual environment.
I was using Tor 0.2.8.9 then I decided to try older versions but still the same problem.

Child Tickets

Change History (10)

comment:1 Changed 3 years ago by teor

Component: Archived/TorouterCore Tor/Tor
Milestone: Tor: 0.2.9.x-final
Priority: Very HighMedium
Severity: CriticalNormal

Maybe your connection is bad? Maybe your guard is bad?

comment:2 Changed 3 years ago by teor

Owner: ioerror deleted
Status: newassigned

comment:3 Changed 3 years ago by teor

Status: assignednew

comment:4 Changed 3 years ago by arma

One of the big first questions is: are *you* the one overloading your guard, with the traffic you're producing?

Can you tell us more about this phrase "connect my RDP's through tor"?

What sort of traffic, and circuits, is your Tor client putting out?

In particular, since you're not using your Tor client in a standard configuration: what sort of stream isolation is your Tor client set up to do?

comment:5 Changed 3 years ago by bug_bunny

One of the big first questions is: are *you* the one overloading your guard, with the traffic you're producing?
No, I dont think so because I capped my bandwidth at 96K(B)ps.

Can you tell us more about this phrase "connect my RDP's through tor"?
I am running monero nodes on few vps and I use tor to connect them after every few days.

What sort of traffic, and circuits, is your Tor client putting out?
Normal searching and occasionally youtube videos.

Is this information enough to explain me what is going on?

comment:6 Changed 2 years ago by cypherpunks

Keywords: performance added
Milestone: Tor: 0.2.9.x-finalTor: 0.3.1.x-final

On a fresh TBB 7.0a4 installation Tor messages appear with every start:

Tor NOTICE: Your Guard PrasketTor3 ($3A574F1E28F78CDA49975C2B20B6709AA0219C87) is failing more circuits than usual. Most likely this means the Tor network is overloaded. Success counts are 106/153. Use counts are 45/60. 146 circuits completed, 15 were unusable, 25 collapsed, and 102 timed out. For reference, your timeout cutoff is 60 seconds.
Tor NOTICE: Your Guard PrasketTor3 ($3A574F1E28F78CDA49975C2B20B6709AA0219C87) is failing to carry more streams on its circuits than usual. Most likely this means the Tor network is overloaded or your network connection is poor. Use counts are 45/60. Success counts are 110/157. 150 circuits completed, 15 were unusable, 25 collapsed, and 102 timed out. For reference, your timeout cutoff is 60 seconds.

And there are timeouts/etc even when browsing through the Trac.
Other TBB installations are working fine. So it is that US Guard sucks. But as guards are persistent now, it looks like a punishment to the user, and he blames Tor Browser.
What is the correct way to workaround it in GUI from the user's side?

comment:7 Changed 23 months ago by nickm

Milestone: Tor: 0.3.1.x-finalTor: 0.3.3.x-final

comment:8 Changed 22 months ago by cypherpunks

i see these logs a lot on a 3G mobile broadband connection with an internet telco that heavily tampers with connections to tor

but how they do it i dont know

what tools can i use to try and gather evidence of this tampering?

is this flooding multiple TCP duplicate ACKS?

is this more common on a tor alpha or RC version ?

i can promise you that i never see this at local cafes and connections to tor are fine

comment:9 Changed 22 months ago by cypherpunks

BTW regardless if i use tor stable, RC or alpha, i never see this at an un-censored wifi cafe, but it always happens on my particular 3G mobile broadband telco

comment:10 Changed 18 months ago by dgoulet

Resolution: not a bug
Status: newclosed

Not much we can do here... This warning is unfortunately something that happens and can be often caused by the client seeing it. And this is more a thing right now with the ongoing load.

Closing this because there is really no action items for tor and we are working actively on improving the load situation on the network.

Note: See TracTickets for help on using tickets.