Opened 3 years ago

Closed 3 years ago

#20616 closed defect (fixed)

obfs4proxy package on deb.tp.o is out of date?

Reported by: arma Owned by: lunar
Priority: Medium Milestone:
Component: Internal Services/Service - deb.tpo Version:
Severity: Normal Keywords:
Cc: weasel, yawning Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

http://deb.torproject.org/torproject.org/dists/obfs4proxy/main/binary-amd64/Packages makes it look like we're shipping obfs4proxy 0.0.4 on deb.torproject.org.

Whereas Debian sid, and apparently ubuntu 16.04, have obfs4proxy 0.0.6:
https://packages.debian.org/sid/obfs4proxy

Are we not keeping our deb repo up-to-date?

It doesn't seem reasonable to think that we're shipping jessie's stable, because that looks to be version 0.0.3:
https://packages.debian.org/search?keywords=obfs4proxy

Moritz points out that our current stackexchange answer suggests to use the Tor obs4proxy repo:
https://tor.stackexchange.com/questions/6370/how-to-run-an-obfs4-bridge/6371

Are we at the point where we should stop maintaining our own? Or did that ship sail when we started doing it?

Child Tickets

Change History (4)

comment:1 Changed 3 years ago by arma

Owner: changed from asn to lunar
Status: newassigned

comment:2 Changed 3 years ago by arma

Also, when we figure out the answer for obfs4proxy, I'll be asking the same question about the obfsproxy package there. :)

comment:3 Changed 3 years ago by arma

Component: Obfuscation/ObfsproxyInternal Services/Service - deb.tpo

comment:4 Changed 3 years ago by lunar

Resolution: fixed
Status: assignedclosed

Packages on deb.torproject.org are now up-to-date with version 0.0.7. Please ping me if I forget to update them in the future.

Note: See TracTickets for help on using tickets.