Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#20627 closed defect (duplicate)

6.5a3 is not starting on MacOS Sierra 10.12.1

Reported by: thinkdifferent321 Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I've alwasys had both Stable and Experimental Tor Browsers installed on my MacBook Pro OS Sierra 10.12.1 but recently 6.5a changed that

6.0.5 opens and works fine although ...

When I installed and opened 6.5a3 I got this message: "Tor exited during startup. This might be due to an error in your torrc file, a bug in Tor or another program on your system, or faulty hardware. Until you fix the underlying problem and restart Tor, Tor Browser will not start."

When I got back to open 6.0.5 I got the same message.

If I completely uninstall and erase all files (including preferces files) related to both TorBrowsers using AppleCleaner I can use 6.0.5 and 6.5a3 seperately.

Any issues to fix here? How can I help you to fix this?

Child Tickets

Attachments (1)

Screen Shot 2016-11-10 at 2.10.46 PM.png (43.0 KB) - added by thinkdifferent321 3 years ago.
Screentshot of error

Download all attachments as: .zip

Change History (6)

comment:1 Changed 3 years ago by teor

Component: - Select a componentApplications/Tor Browser
Keywords: 6.5a3 Tor exited during startup removed
Owner: set to tbb-team
Priority: ImmediateMedium
Severity: CriticalNormal
Version: Tor: unspecified

This issue could be related to either:

  • spaces in unix sockets, and the shared tor data directory in Application Support, or
  • using the same torrc (and therefore SOCKSPort) due to the shared tor data directory in Application Support.

But we can't tell unless we can see Tor's log messages.
They might be in ~/Library/Application\ Support/TorBrowser-Data/Tor/notice.log
Or they might be available through a button in the "Tor exited during startup" message window.

comment:2 Changed 3 years ago by gk

Resolution: duplicate
Status: newclosed

Duplicate of #20210. Note comment:15:ticket:20210 and comment:16:ticket:20210 explain what is going on and contain workarounds. This will be fixed in 6.5a4.

comment:3 Changed 3 years ago by gk

The root cause is actually #18753 but the Tor Browser related pieces get discussed in #20210.

Changed 3 years ago by thinkdifferent321

Screentshot of error

comment:4 Changed 3 years ago by thinkdifferent321

so I guess it's a known problem? and will be fixed?

comment:5 in reply to:  4 Changed 3 years ago by teor

Replying to thinkdifferent321:

so I guess it's a known problem? and will be fixed?

Yes, in 6.5a4.

One workaround for some of these issues is to delete "~/Library/Application Support/TorBrowser", then run each copy of Tor Browser from a different directory. (You will lose all your bookmarks and customisations if you delete this directory.)

Note: See TracTickets for help on using tickets.