Opened 2 years ago

Closed 5 months ago

Last modified 5 months ago

#20628 closed defect (fixed)

More locales for Tor Browser

Reported by: arthuredelstein Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-torbutton, tbb-easy, ux-team, TorBrowserTeam201806
Cc: phoul Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description (last modified by arthuredelstein)

Several locales for torbutton in Transifex are fully or almost fully translated, but we aren't including these in our ./import_translations.sh script in torbutton.

And we would probably like to release some of these as Tor Browsers as well.

Child Tickets

TicketStatusOwnerSummaryComponent
#25575closedtpaServer space request (175 GB total) for hosting Tor Browser downloadsInternal Services/Tor Sysadmin Team

Change History (20)

comment:1 Changed 2 years ago by gk

Keywords: tbb-torbutton tbb-easy added

comment:2 Changed 19 months ago by arthuredelstein

Description: modified (diff)

comment:3 Changed 19 months ago by arthuredelstein

Cc: phoul added

comment:4 Changed 17 months ago by mcs

During today's localization AMA, Roger suggested that we ship a nightly Tor Browser build that includes all available translations. Doing so would provide a way for translators to check their work before a Tor Browser that includes a new language is available.

comment:5 in reply to:  4 Changed 17 months ago by mcs

Replying to mcs:

During today's localization AMA, Roger suggested that we ship a nightly Tor Browser build that includes all available translations. Doing so would provide a way for translators to check their work before a Tor Browser that includes a new language is available.

I created #22710 to track this idea.

comment:6 in reply to:  description ; Changed 17 months ago by arma

Replying to arthuredelstein:

Several locales for torbutton in Transifex are fully or almost fully translated, but we aren't including these in our ./import_translations.sh script in torbutton.

And we would probably like to release some of these as Tor Browsers as well.

Arthur (or Colin): which locales are fully or almost fully translated, yet we don't have Tor Browser versions of them?

Even if we have to do a "popular languages are on the main download page" and "less popular language are tucked away over here" division for good user experience, we should make the builds for the people who want those languages.

comment:7 Changed 17 months ago by arma

Keywords: ux-team added

Adding the ux-team keyword so Linda et al can say "wait, you have other languages available, and the only thing left is to do the builds? yes, we should do that."

Or she can say something different if she prefers. :)

comment:8 Changed 17 months ago by phoul

The following languages have enough completion (Tor Button and Launcher) for a Tor Browser, and have support in Firefox-ESR:

Albanian, Shqip 
Basque, Euskara 
Bulgarian, Български 
Catalan, Català 
Czech, Čeština 
Danish, Dansk 
English (British) 
Estonian, Eesti keel 
Finnish, suomi 
Greek, Ελληνικά 
Hungarian, magyar 
Icelandic, íslenska 
Indonesian, Bahasa Indonesia 
Latvian, Latviešu
Lithuanian, lietuvių kalba 
Norwegian (Bokmål), Norsk bokmål 
Romanian, Română 
Slovak, slovenčina 
Swedish, Svenska
Ukrainian, Українська

The following are languages that have partial support for our components, and full Firefox-ESR support:

Azerbaijani, Azərbaycanca
Croatian, Hrvatski
Hebrew, עברית 
Malay, Melayu 
Norwegian (Nynorsk), Norsk nynorsk 
Serbian, Српски 
Slovenian, Slovenščina 
Thai, ไทย 
Welsh, Cymraeg 
Last edited 17 months ago by phoul (previous) (diff)

comment:9 in reply to:  6 Changed 17 months ago by gk

Replying to arma:

Replying to arthuredelstein:

Several locales for torbutton in Transifex are fully or almost fully translated, but we aren't including these in our ./import_translations.sh script in torbutton.

And we would probably like to release some of these as Tor Browsers as well.

Arthur (or Colin): which locales are fully or almost fully translated, yet we don't have Tor Browser versions of them?

Even if we have to do a "popular languages are on the main download page" and "less popular language are tucked away over here" division for good user experience, we should make the builds for the people who want those languages.

You might like #17400 I guess.

comment:10 Changed 12 months ago by kscanne

Just adding a note to ensure that our Irish translation (ISO 639 "ga") doesn't fall through the tracks, since we're not included in the list of potential locales above. We're translated/reviewed to 100% in Transifex in all Tor projects, and have support in Firefox-ESR (all versions back to FF1.0). Anything I can do to help move this forward? Even short of a full release, a nightly build so we can test the localisation would be a big help.

comment:11 Changed 12 months ago by phoul

Updating the above "completed" list, it should now include:

Irish Gaelic
Hebrew
Indonesian

I have recently received a request asking about timelines for adding these three new languages.

comment:12 Changed 10 months ago by erinm

"Macedonian, Македонски" should be added to the "completed" list. Latest release of Moxilla Firefox ESR is confirmed available and Tor Project resources associated with Tor Browser have been translated.

Is there any progress on making all of the above languages available? If new languages cannot be realistically added to Tor Browser, we may want to consider halting all contributions to languages not currently supported.

comment:13 Changed 10 months ago by arthuredelstein

I created an auto-updating page that lets us see what extra locales are available for Tor Browser:
https://torpat.ch/locales

Right now, the list of possible new locales with 100% coverage (in tor-launcher and torbutton) are:
bg, bn-BD, ca, da, en-GB, fr-CA, ga, he, id, lv, mk, nb, pt, ro, sv, zh-TW

I'd like to propose adding these, with the exception of en-GB, fr-CA, and pt which are probably well-enough covered by en-US, fr, and pt-BR respectively. So the list would be:
bg, bn-BD, ca, da, ga, he, id, lv, mk, nb, ro, sv, zh-TW

comment:14 Changed 10 months ago by gk

What do you mean with "adding these"? I think, again, #17400 is important here. To get some locales of your list added to the current list of bundles we ship I think doing the following in that order is not unreasonable:

1) Find out how many disk space we have available for additional locales (don't forget our mirrors)
2) Find out how many additional bytes Fastly is willing to serve to our users

[For 1) and 2) keep in mind that Win64 bundles are supposed to be stable later this year and that Android apks are planned as well]

3) Order the list you have using some metric so that the N locales we add are most helpful (in case N would be smaller than the amount of items we currently have)
4) Make a plan for #17400.
5) Start shipping N additional locales.

Last edited 10 months ago by gk (previous) (diff)

comment:15 Changed 6 months ago by arma

I just added #11517 as a child ticket, since it's about having a ukrainian tor browser.

comment:16 Changed 5 months ago by arthuredelstein

Keywords: TorBrowserTeam201806R added
Status: newneeds_review

Here are patches for adding 5 new locales for Tor Browser (bn-BD, da, he, sv, zh-TW):

https://github.com/arthuredelstein/torbutton/commit/20628
https://github.com/arthuredelstein/tor-launcher/commit/20628
https://github.com/arthuredelstein/tor-browser-build/commit/20628
https://github.com/arthuredelstein/webml/commit/20628

I haven't finished building Tor Browser to test these new locales yet, but I thought it would be good to make them available for review now.

comment:17 Changed 5 months ago by gk

Keywords: TorBrowserTeam201806 added; TorBrowserTeam201806R removed
Status: needs_reviewneeds_revision

The first two patches look good. I merged them to master (in Torbutton's case commit 46c71b6a528e70386fb8165f7d1507615d1a2a47 and in Tor Launcher's case commit f34580ab7e70487e5c97c67969326111ac00d074)

I think the other two need revision because there is no sv lang pack Mozilla ships, rather sv-SE. The bundle name should match that I think.

comment:18 Changed 5 months ago by gk

Resolution: fixed
Status: needs_revisionclosed

20628+1 looks good to me. I merged it to master (in our tor-browser-build repo) with commit b39dad476f870b60d7008c1e22e477dc80875c38 and we'll pick up the webml change once we update the website.

comment:19 in reply to:  16 ; Changed 5 months ago by boklm

Replying to arthuredelstein:

https://github.com/arthuredelstein/webml/commit/20628

It looks like this commit is adding the new locales to the stable tor release instead of the alpha.

comment:20 in reply to:  19 Changed 5 months ago by boklm

Replying to boklm:

Replying to arthuredelstein:

https://github.com/arthuredelstein/webml/commit/20628

It looks like this commit is adding the new locales to the stable tor release instead of the alpha.

This should be fixed by commits 18744ca9013c74fe9aa7dcee629ce6cc639127bc and 18744ca9013c74fe9aa7dcee629ce6cc639127bc.

Note: See TracTickets for help on using tickets.