#20635 closed defect (worksforme)

Compiling Go 1.7.3 is randomly segfaulting targeting 32bit Linux

Reported by: gk Owned by: tbb-team
Priority: High Milestone:
Component: Applications/Tor Browser Version:
Severity: Major Keywords: tbb-gitian
Cc: boklm, dcf Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description (last modified by gk)

I mentioned in #20023 that compiling Go 1.7.3 is segfaulting on 32bit Linux. The build log shows

 + cd go/src
 + ./make.bash
 ##### Building Go bootstrap tool.
 cmd/dist

 ##### Building Go toolchain using /home/debian/build/go1.4.
 bootstrap/internal/sys
 bootstrap/asm/internal/flags
 bootstrap/internal/bio
 bootstrap/compile/internal/big
 bootstrap/internal/gcprog
 bootstrap/internal/obj
 bootstrap/internal/obj/arm
 bootstrap/internal/obj/arm64
 bootstrap/internal/obj/mips
 bootstrap/internal/obj/ppc64
 bootstrap/internal/obj/s390x
 bootstrap/internal/obj/x86
 bootstrap/asm/internal/lex
 bootstrap/link/internal/ld
 bootstrap/asm/internal/arch
 bootstrap/compile/internal/ssa
 bootstrap/asm/internal/asm
 bootstrap/asm
 bootstrap/link/internal/amd64
 bootstrap/link/internal/arm
 bootstrap/link/internal/arm64
 bootstrap/link/internal/mips64
 bootstrap/link/internal/ppc64
 bootstrap/link/internal/s390x
 bootstrap/link/internal/x86
 bootstrap/link
 bootstrap/compile/internal/gc
 go build bootstrap/compile/internal/gc:
 /home/debian/build/go1.4/pkg/tool/linux_386/8g: signal: segmentation fault
 go tool dist: FAILED: /home/debian/build/go1.4/bin/go install -gcflags=-l
 -v bootstrap/...: exit status 1

It seems there is more to it than just some weird problem with my machine as boklm hit the error as well, this time when trying to build 6.5a4.

Child Tickets

Change History (7)

comment:1 Changed 23 months ago by gk

Description: modified (diff)

comment:2 Changed 23 months ago by gk

Cc: dcf added; dcf1 removed

comment:3 Changed 23 months ago by dcf

I haven't been able to reproduce this myself yet. If it doesn't happen every time, it seems it must have to do with available memory or something.

I searched for the error message and found a couple of links that might be interesting.

https://groups.google.com/d/topic/golang-nuts/iaRU2yM0yCw
I have been trying to build golang 1.5.0 with golang 1.4.2 bootstrap binaries. My build host is centos5 and build is yocto build. But I always get below compilation issue.

##### Building Go bootstrap tool.
| cmd/dist
| go build _/local/jenkins/ws/CB/160921103249-broadcom-ns2-emgw-3.10-1.4/i686/build-project/tmp/work/aarch64-montavista-linux/golang/1.5-r0/go/src/cmd/dist: /local/jenkins/ws/CB/160921103249-broadcom-ns2-emgw-3.10-1.4/i686/build-project/tmp/work/aarch64-montavista-linux/golang/1.5-r0/go1.4.2/go/pkg/tool/linux_386/8g: signal: segmentation fault
| ERROR: build failed

The reply says that cause is a too-old kernel (CentOS 5). This one is recent, 1.5 months ago.

An old, closed ticket from 2010:

https://github.com/golang/go/issues/869

This one seems to have been caused by linking with a specific version of gold, which I don't think applies to us.o

comment:4 Changed 20 months ago by gk

Maybe not surprisingly but still noteworthy: I hit this with 1.7.4 again. Just restarting the build solved this for me, though.

comment:5 Changed 19 months ago by dcf

Did this affect you while building 6.5.1/7.0a2?

I still don't have a guess about the cause. However I opened tickets for two Go upgrades, that may be worth a try: #21709 #21710.

comment:6 in reply to:  5 Changed 19 months ago by gk

Replying to dcf:

Did this affect you while building 6.5.1/7.0a2?

I still don't have a guess about the cause. However I opened tickets for two Go upgrades, that may be worth a try: #21709 #21710.

I still hit it while building 6.5 IIRC, so moving the go build right at the beginning of the whole compilation dance did not resolve the issue (one of my guesses had been that it is related to the previous 64 bit firefox building but that is moot now).

comment:7 Changed 13 months ago by gk

Resolution: worksforme
Status: newclosed

We have not been hitting this problem recently with rbm. Thus, closing as WORKSFORME now. Please reopen in case anyone encounters this with the new build system.

Note: See TracTickets for help on using tickets.