Opened 3 years ago

Closed 23 months ago

#20636 closed defect (fixed)

Create 64bit Tor Browser for Windows

Reported by: gk Owned by: tbb-team
Priority: Very High Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-rbm, TorBrowserTeam201711R
Cc: boklm Actual Points:
Parent ID: Points:
Reviewer: Sponsor: Sponsor4

Description

Mozilla's move to 64bit versions of Firefox for Windows has reached a sufficiently stable state that we can start working on 64bit Tor Browser builds for Windows. This is the parent ticket for all pieces involved.

Child Tickets

TicketStatusOwnerSummaryComponent
#10026closedtbb-teamprogress on Win64 TorApplications/Tor bundles/installation
#23228closedtbb-teamBuild a Windows 64 toolchain based on mingw-w64Applications/Tor Browser
#23229closedboklmBuild firefox for Windows 64Applications/Tor Browser
#23456closedboklmBuild go and go pluggable transports for Windows 64Applications/Tor Browser
#24060closedtbb-teamAdd x86_64 version of msvcr100.dllApplications/Tor Browser

Change History (20)

comment:1 Changed 3 years ago by gk

#9820 and #7956 might be worth taking into account as well.

comment:2 Changed 3 years ago by gk

Sponsor: Sponsor4

comment:3 Changed 2 years ago by gk

Keywords: TorBrowserTeam201709 added

Adding to our September 2017 tickets.

comment:4 Changed 2 years ago by gk

Keywords: tbb-rbm added; tbb-gitian removed

Moving over to rbm

comment:5 Changed 2 years ago by gk

Keywords: TorBrowserTeam201710 added; TorBrowserTeam201709 removed

Items for October 2017

comment:6 Changed 23 months ago by boklm

I did two builds on two computers with make testbuild-windows-x86_64 from branch boklm/bug_20636_v9 and got the same result, so the build seems to be reproducible.

comment:7 Changed 23 months ago by boklm

Currently the filename for a 32bit build is torbrowser-install-7.5a7_en-US.exe. I am not sure what the filename for a 64bit build should be.

Maybe torbrowser-install-win64-7.5a7_en-US.exe?

comment:8 in reply to:  7 Changed 23 months ago by gk

Replying to boklm:

Currently the filename for a 32bit build is torbrowser-install-7.5a7_en-US.exe. I am not sure what the filename for a 64bit build should be.

Maybe torbrowser-install-win64-7.5a7_en-US.exe?

Sounds good to me.

comment:9 Changed 23 months ago by gk

Keywords: TorBrowserTeam201711 added; TorBrowserTeam201710 removed

Moving tickets over to November.

comment:10 Changed 23 months ago by gk

Priority: HighVery High

Changing prio to reflect sponsor deadline

comment:11 Changed 23 months ago by gk

Seems we are good here apart from adapting the Makefile to add a new win64 target?

comment:12 Changed 23 months ago by boklm

Keywords: TorBrowserTeam201711R added; TorBrowserTeam201711 removed
Status: newneeds_review

comment:13 Changed 23 months ago by gk

Resolution: fixed
Status: needs_reviewclosed

Those look good to me, thanks. I merged them to master as
commit 4f71f0121be989e80a74cc7f0d476407bf7fc329
commit 5341706993dfa6ee3b2c8b674e003eeb9e09c1c0
commit d0a79f2f2422cfac5155a7f455136e295b50ef95
commit 5a89431f10be74e1f08cdd804d24999ffd899426
commit fa215970fa0bd34454999ea5a92fe565f80dac7f
commit c00ea668caa435a6e7aa56fefc0470102df2fcbf
commit d37b7a0e0de0057a7a44ae36ac6f10a849299e2a

boklm: Could you open a follow-up ticket for the FTE build please?

comment:14 Changed 23 months ago by gk

Resolution: fixed
Status: closedreopened

comment:15 Changed 23 months ago by gk

Resolution: fixed
Status: reopenedclosed

comment:16 Changed 23 months ago by boklm

I created #24195 for the fteproxy and obfsproxy part.

comment:17 Changed 23 months ago by boklm

I created #24196 for updating 64bit users to the Windows 64 version.

comment:18 Changed 23 months ago by boklm

Resolution: fixed
Status: closedreopened

comment:19 Changed 23 months ago by boklm

Status: reopenedneeds_review

comment:20 Changed 23 months ago by gk

Resolution: fixed
Status: needs_reviewclosed

This is commit 3c517c1a36a4e9f1251679fc4c129569a874be76 on master now, thanks.

Note: See TracTickets for help on using tickets.