Opened 19 months ago

Closed 19 months ago

Last modified 19 months ago

#20645 closed defect (invalid)

No command line ouptut under Windows 7, hence cannot get my hashed password

Reported by: sly1 Owned by: erinn
Priority: Medium Milestone:
Component: Applications/Tor bundles/installation Version: Tor: 0.2.8.7
Severity: Normal Keywords: hashed password
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Tried

tor --hash-password "my_password"

and got no ouput whatsoever. Also this is the case with

tor -h

and any other command, for that matter. Tor was bundled with last "tor browser bundle", Version 6.0.5 (2016-09-16) for Windows 10, 8, 7, Vista, and XP.
Log file says it's Tor 0.2.8.7
Running as administrator.

Child Tickets

Change History (3)

comment:1 Changed 19 months ago by arma

Component: - Select a componentApplications/Tor bundles/installation
Milestone: Tor: 0.2.8.x-final
Owner: set to erinn

I think on Windows you want the tor.exe from the "expert bundle" -- it is built to give you a window when it runs.

That said, maybe it (the tor from the expert bundle) gives you that window, but the window disappears when it finishes running? I would not be surprised.

comment:2 Changed 19 months ago by sly1

Resolution: invalid
Status: newclosed

comment:3 Changed 19 months ago by sly1

As it happens, this was by design. "expert bundle"'s tor.exe have an output, and tor.exe from "tor browser bundle" is silent.

Note: See TracTickets for help on using tickets.