Opened 3 years ago

Closed 3 years ago

#20690 closed defect (duplicate)

cookie settting changes on cancel

Reported by: Wyom123 Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: ux
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

hello tbb-team,

concerns tor browser bundle 6.0.6 and 6.0.5 ( maybe others too )

if you change setting in: preferences / privacy / Tor Browser will: [---] tbb says that browser needs to be restarted. When cancelling that then "Tor Browser will: [---]" changes back accordingly ( as in cancelled indeed ) but the cookie setting for third party changes ( or stays changed ) to "always" after the cancel.
( do not know if that has real effect or just a GUI hickup )

related remark: when selected "accept cookies" no cookies are shown at "show cookies" button. Maybe none are accepted due to private browsing but than one would expect that cookie setting indicates so by means of clearing its tick box. For users to see the current situation instead of (maybe) having to think in overrides would be more intuitive.

thanks for your attention,
wyom123

Child Tickets

Attachments (2)

Scrnsht_trbrbl.png (117.6 KB) - added by Wyom123 3 years ago.
Scrnsht_cookie.png (96.2 KB) - added by Wyom123 3 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 3 years ago by isis

Hello wyom123, thanks for reporting this! I'm having a bit of trouble understanding which part of the menu is showing this glitch… do you think you could either walk me through how you got there or maybe upload a screen shot of the 3rd party cookie settings being stuck on "always"?

comment:2 Changed 3 years ago by isis

Component: - Select a componentApplications/Tor Browser
Keywords: ux added
Owner: set to tbb-team

Setting component to Tor Browser, but this might actually be a Torbutton bug in the "Cookie Protections" menu… I'm not sure yet.

Changed 3 years ago by Wyom123

Attachment: Scrnsht_trbrbl.png added

Changed 3 years ago by Wyom123

Attachment: Scrnsht_cookie.png added

comment:3 Changed 3 years ago by Wyom123

here are some screenshots (where I could add them, unfamiliar with this site ).

(first attach)
at the green arrow 4: make a change, then when tbb says "need restart" cancel.
that cancel will work at arrow 4, but at green arrow 5 the "never" stays changed to "always"

(second attach)
in second screenshot the red arrows seem to indicate cookies are accepted but none will show (or have not been accepted and therefore nothing to show )

hope this helps.

comment:4 Changed 3 years ago by Wyom123

update:
figured out (maybe common knowledge) that firefox does not show session cookies.
it even denies (depending on choice/meaning of words) that a site has been visited prior today
on ctrl+I / security while http://www.whatarecookies.com/cookietest.asp tells differently on reload and also on closing tab and revisit in other tab. ( that site connects to other sites as well like facebook google and the like, which is less brilliant )
ctrl + shift + del does not show any result for clearing on tbb version of firefox
also re-enabling menu bar to access clearing cookies ( via tools clear recent history or something) did not result in a usefull option.
I have to test yet that "new identity" is the way to go to clear memory cookies ??

comment:5 Changed 3 years ago by Wyom123

ok, indeed "new identity" seems to clear memory cookies

comment:6 Changed 3 years ago by gk

Resolution: duplicate
Status: newclosed

That cookies are not shown is #10353. The other basically issue #10824. Calling this a duplicate of the latter.

Note: See TracTickets for help on using tickets.