Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#20733 closed defect (fixed)

Onionoo downloads html

Reported by: iwakeh Owned by: metrics-team
Priority: Medium Milestone:
Component: Metrics/Onionoo Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

A single run of Onionoo led to the following error(s):

... ERROR o.t.o.u.DescriptorQueue:217 Could not parse /srv/org.torproject.onionoo/onionoo/in/recent/relay-descriptors/extra-infos/?C=N;O=A
org.torproject.descriptor.DescriptorParseException: Could not detect descriptor type in descriptor starting with '<!DOCTYPE html>
<html lang="en">
<head>
<meta charset="utf-8">
<meta http-equiv="X-UA-Compatible" co'.
        at org.torproject.descriptor.impl.DescriptorImpl.parseDescriptors(DescriptorImpl.java:110) ~[onionoo-3.1-0.9.0-dev.jar:3.1-0.9.0-dev-3b4ddac]
        at org.torproject.descriptor.impl.DescriptorParserImpl.parseDescriptors(DescriptorParserImpl.java:26) ~[onionoo-3.1-0.9.0-dev.jar:3.1-0.9.0-dev-3b4ddac]
...  

Should be avoided.

Child Tickets

Change History (3)

comment:1 Changed 3 years ago by karsten

Right, I think the issue is that Onionoo still contains code similar to what's in metrics-lib's DescriptorCollectorImpl. Shouldn't be hard to take that out and use metrics-lib's DescriptorCollector implementation instead.

comment:2 Changed 3 years ago by iwakeh

Resolution: fixed
Status: newclosed

metrics-lib default changed as suggested above. Thus, this is resolved.

Closing.

comment:3 Changed 3 years ago by iwakeh

Milestone: Onionoo 3.1-1.1.0

Not part of any milestone.

Note: See TracTickets for help on using tickets.