Opened 3 years ago

Closed 3 years ago

#20798 closed defect (fixed)

tor browser sandbox fails to connect to tor and loops

Reported by: femm Owned by: yawning
Priority: Medium Milestone:
Component: Archived/Tor Browser Sandbox Version:
Severity: Normal Keywords:
Cc: yawning Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I get an error message: "Failed to launch Tor Browser: dial unix ~/.local/share/sandboxed-tor-browser/tor/control: connect: connection refused" on launch. Clicking OK shows the configuration UI but then clicking connect gives the first error message again ("failed to launch....").

the terminal reports:
[notice] DisableNetwork is set. Tor will not make or accept non-control network connections. Shutting down all existing connections.
[warn] It looks like another Tor process is running with the same data directory. Waiting 5 seconds to see if it goes away.
[err] No, it's still there. Exiting.

Child Tickets

Change History (5)

comment:1 Changed 3 years ago by yawning

Priority: HighMedium

This bug report is totally worthless without anything that can be used to reproduce this (platform, os, etc). Try killing off old processes if there are any.

comment:2 Changed 3 years ago by femm

Oh, I thought looping like this without any indication on how to fix it was a problem on all platforms.

Ubuntu latest LTS amd64; it used to work even with old processes. Killing the process first works, but why would I have to kill my system tor to use a sandbox? I killed it and started my system tor again after connecting with tor browser sandbox but I don't see why tor browser sandbox could not just ignore my system tor if it could not connect.

I also noticed that unlike tor-launcher/button it cannot handle its tor process being killed, it won't ask to start another instead it says

"Torbutton cannot safely give you a new identity. It does not have access to the Tor Control Port. Are you running Tor Browser Bundle?" With the Only option being "OK".

Last edited 3 years ago by femm (previous) (diff)

comment:3 Changed 3 years ago by yawning

I don't see why tor browser sandbox could not just ignore my system tor if it could not connect.

If you point it at a system tor, it will use it. Otherwise it will assume that you want to launch one. I don't see myself changing this behavior.

Well, I made the error handling better, since there was an issue of stale tor processes being left behind by the sandbox in certain cases, so it's better about cleaning up after itself on failures now.

https://gitweb.torproject.org/tor-browser/sandboxed-tor-browser.git/commit/?id=ca15fda88cf2b304cf16deb7416c531798c48e08

I also noticed that unlike tor-launcher/button it cannot handle its tor process being killed

So don't kill it. I'm not changing this either.

comment:4 Changed 3 years ago by cypherpunks

If you point it at a system tor, it will use it. Otherwise it will assume that you want to launch one. I don't see myself changing this behavior.

I didn't point it to anything, I just happened to have torified processes running - all of which I had to kill before starting the sandbox.

So don't kill it.

It should at least tell the user that the tor process has been killed and that new connections won't work, and not just ask something as vague as if you're running tor browser bundle.

I'm not changing this either.

So if tor crashes the user is just out of luck.

comment:5 Changed 3 years ago by yawning

Resolution: fixed
Status: newclosed

I'm fairly sure I stomped out the worst of this with:

ca15fda88cf2b304cf16deb7416c531798c48e08
0ba177e4136ea2459741a5de283d6ada6c3b8d63
60e6f8baa63c1342300261566dda1b9361a5f11b

Note: See TracTickets for help on using tickets.