Opened 3 years ago

Closed 3 years ago

#20801 closed defect (worksforme)

atlas should show "Last Restarted" either in UTC or should show the time zone

Reported by: toralf Owned by: irl
Priority: Low Milestone:
Component: Metrics/Relay Search Version: Tor: 0.2.9.5-alpha
Severity: Minor Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Atlas shows correctly "2016-11-26 19:10:32" for my relay (https://atlas.torproject.org/#details/1AF72E8906E6C49481A791A6F8F84F8DFEBBB2BA) - but that is UTC+1.

Child Tickets

Change History (3)

comment:1 Changed 3 years ago by karsten

Status: newneeds_information

Hmm, I cannot confirm this issue. Right now, Atlas says that your relay was last restarted at 2016-12-02 17:25:59, which is UTC. Onionoo says the same: "last_restarted":"2016-12-02 17:25:59". And your relay server descriptor contains the lines published 2016-12-03 06:38:21 and uptime 47542, which leads to the same UTC time (using R): as.POSIXct("2016-12-03 06:38:21", tz = "UTC") - 47542 == [1] "2016-12-02 17:25:59 UTC".

Can you look again and say which of these sources shows you a different timestamp?

comment:2 Changed 3 years ago by toralf

indeed, it is right now (well, I do have 0.2.9.6-rc since yesterday but that shouldn't make a difference)

comment:3 Changed 3 years ago by karsten

Resolution: worksforme
Status: needs_informationclosed

Okay. Then let's close this as works-for-me. Note that this is unrelated to #20802 which uses different functions for parsing and formatting timestamps. Thanks for the report anyway! Closing.

Note: See TracTickets for help on using tickets.