Opened 3 years ago

Closed 3 years ago

#20865 closed defect (fixed)

Tor 0.2.8.10 breaks compilation on macOS Sierra

Reported by: teor Owned by:
Priority: High Milestone: Tor: 0.2.8.x-final
Component: Core Tor/Tor Version: Tor: 0.2.8.10
Severity: Major Keywords: regression macos
Cc: Actual Points:
Parent ID: Points: 0.1
Reviewer: Sponsor:

Description

We forgot to backport the sys/random.h header include and its check.
This means that tor 0.2.8.10 compiles on pre-sierra systems, but not on sierra itself.

Child Tickets

Change History (3)

comment:1 Changed 3 years ago by nickm

Hm. For 0.2.8, I think I would rather not backport, but instead do

#ifdef __APPLE__
#undef HAVE_GETENTROPY
#endif

comment:2 Changed 3 years ago by teor

Works for me.
Edit: that solution seems like a good one to me.

Last edited 3 years ago by teor (previous) (diff)

comment:3 Changed 3 years ago by nickm

Resolution: fixed
Status: newclosed

714aeedc5278fe50fb2b9ccafeefa4270eaf3391 is the fix, tested, with a changes file and some comments.

Note: See TracTickets for help on using tickets.