Opened 9 years ago

Closed 9 years ago

Last modified 7 years ago

#2087 closed defect (duplicate)

Tor use 100% of one of the cores in multithread system

Reported by: stars Owned by:
Priority: Medium Milestone: Tor: unspecified
Component: Core Tor/Tor Version:
Severity: Keywords: tor-relay
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Hi,

From a couples weeks, Tor is using 100% of one core from my 4 .

I running kubuntu Lucid 10.04.1 x86 64 ( 4 cores ), relay non-exit ,

So it start with core "1" at 100 % a few time after the use the "2" at 100% a few time and the "3" ect.. Early it never does that, so it must be appear quite recently.

Tor: commit 4dbd8ba008de7eea623e3b760a6c43040d145a8d
libevent: commit f13e449b531bb14d076e28660e2d33fb6fb255ab
arg at compile: --with-libevent-dir=/usr/local/lib/ --enable-gcc-warnings --enable-gcc-hardening --enable-linker-hardening

torrc:

# This file was generated by Tor; if you edit it, comments will not be preserved
# The old torrc file was renamed to torrc.orig.1 or similar, and Tor will ignore it

CellStatistics? 1
ContactInfo? swisstorexit at Safe-mail dot net
ControlPort? 9051
DataDirectory? xxxxxxxxxxxxxxxxxxxxxxxxxxxx
DirListenAddress? 0.0.0.0:9091
DirPort? 443
DirReqStatistics? 1
DNSPort 53
DNSListenAddress 127.0.0.1:9053
EntryStatistics? 1
ExcludeNodes? xxxxxxxxxxxxxxxxxxxxxxxxxx
ExcludeExitNodes? xxxxxxxxxxxxxxxxxxx
ExitPolicy? reject *:*
ExtraInfoStatistics? 1
GeoIPFile xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
HashedControlPassword? xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
Log notice stdout
Nickname SwissTorHelp?
NumCpus? 4
NumEntryGuards? 8
ORListenAddress 0.0.0.0:9090
ORPort 80
RefuseUnknownExits? 1
RelayBandwidthBurst? 1024000
RelayBandwidthRate? 409600

Linux xxxxxxxxx 2.6.32-25-generic #44-Ubuntu SMP Fri Sep 17 20:05:27 UTC 2010 x86_64 GNU/Linux

Child Tickets

Change History (8)

comment:1 Changed 9 years ago by nickm

Milestone: Tor: unspecified
Version: Tor: unspecified

Hm. So there are at least 2 issues here. One is CPU usage, one is bad balancing.

Bad crypto load-balancing is a known bug that we're trying to fix during 0.2.3.x series; #1749 is the main ticket for that.

But it's also possible that we're doing something dumb that pegs one of the CPUs.

If you (or anybody) has a chance, it would be good to get oprofile numbers out of a relatively busy Linux server just to see whether we're wasting time somewhere crazy.

I'm putting this in the "unspecified" milestone for now, pending profile results. If they look reasonable, we should close this as a duplicate of #1749. If there's something stupid going on, we should reassign this bug, and fix it in 0.2.2 or 0.2.3.

comment:2 Changed 9 years ago by stars

Hi nickm,

With the new code in Tor to fix (fix2204) the TLS error with new openssl , now the relay are running like previously with less CPU and seem have a better load balancing.

I use 1% on my 4 cores and it never block at 100% anymore so far.

Seem fixed on: commit 926b188d8eb7fc3471257ff31355d7d49ea12fad

system: 4 cores 2.88 Mhz x86 64

I keep in touch if i get again busy cores.

comment:3 Changed 9 years ago by stars

hi nickm,

I have updated to last origin/master 0.2.3.0-alpha-dev commit d77bc69b0cd1fe6886929d5d575180ac195906ed and it do the same problem as before, i have again the CPU at 100% used all the times.

Best regards

comment:4 Changed 9 years ago by arma

Seems like we should close this as a duplicate of #1749, and continue begging people for oprofile outputs as usual. If we get one, we can then open some trac entries if there appear to be other bugs.

comment:5 Changed 9 years ago by stars

Hi arma, yes, i agree, from now quite 2 months, all last git origin/master branch worked good.

I never has anymore 100% of cores used and never get up 1 to 2 % and load balancing look good too now.

Best regards

SwissTorExit

comment:6 Changed 9 years ago by nickm

Resolution: duplicate
Status: newclosed

Closing as duplicate.

comment:7 Changed 7 years ago by nickm

Keywords: tor-relay added

comment:8 Changed 7 years ago by nickm

Component: Tor RelayTor
Note: See TracTickets for help on using tickets.