Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#20905 closed defect (fixed)

Tor Browser window does not get resized to the same sizes as before 6.5a4 anymore

Reported by: gk Owned by: tbb-team
Priority: High Milestone:
Component: Applications/Tor Browser Version:
Severity: Major Keywords: tbb-6.5-regression, tbb-usability, tbb-fingerprinting-resolution, TorBrowserTeam201704, ff52-esr-will-have
Cc: arthuredelstein, amd64 Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

After switching to 6.5a4 I noticed that my Tor Browser window's height is less than it was before 6.5a4. In both cases it was/is rounded properly though. Thus, it seems that the new code is not really using the available space as it could.
This happens on a Linux box (Debian testing) with XFCE.

Child Tickets

Attachments (1)

more_than_maximized_linux64_xfce.png (122.4 KB) - added by gk 2 years ago.

Download all attachments as: .zip

Change History (19)

comment:1 Changed 2 years ago by gk

Keywords: tbb-fingerprinting-resolution added; tbb-fingerprinting-resize removed

comment:2 Changed 2 years ago by cypherpunks

Also Gentoo XFCE after upgrading to 6.5a5. The default new window size changed from 1000x1000 px to 1000x900 px.

comment:3 Changed 2 years ago by gk

Keywords: tbb-6.5-regression added

comment:4 Changed 2 years ago by cypherpunks

Keywords: tbb-usability tbb-fingerprinting-resolution removed
Status: newneeds_information

it was/is rounded properly

So, not a fingerprinting issue.

code is not really using the available space as it could.

The available space could be seen in debug log during startup, e.g.:

Torbutton INFO: Initializing the Torbutton button.
Torbutton INFO: init completed
Torbutton INFO: Window: (132,38) ?= (1920,1160)
Torbutton DBUG: Window is normal

for 1920x1200 monitor. So, if you have 1080p monitor you should check how much space is available after XFCE takes some. And if it takes more than 80px (<1000 available), then it's not a bug.

comment:5 Changed 2 years ago by gk

Keywords: tbb-usability tbb-fingerprinting-resolution added

comment:6 Changed 2 years ago by gk

Taking this as the bug for investigating reduced screen sizes due to our Firefox patch. A user reports getting a new window size of 800x600 while they had 1000x600 before: https://blog.torproject.org/blog/tor-browser-65-released#comment-232732.

comment:7 Changed 2 years ago by gk

Keywords: TorBrowserTeam201701 added

Arthur, can you take a look at it?

comment:8 Changed 2 years ago by gk

Priority: MediumHigh
Severity: NormalMajor

comment:9 Changed 2 years ago by gk

Cc: amd64 added
Status: needs_informationassigned

#21333 is a duplicate.

comment:10 Changed 2 years ago by cypherpunks

Similarly 1000x500 instead of 1000x600 on Windows 7

comment:11 Changed 2 years ago by gk

Keywords: TorBrowserTeam201702 added; TorBrowserTeam201701 removed

Moving our tickets to Feb 2017.

comment:12 in reply to:  2 Changed 2 years ago by cypherpunks

Replying to cypherpunks:

Also Gentoo XFCE after upgrading to 6.5a5. The default new window size changed from 1000x1000 px to 1000x900 px.

I have an update to this. I have two displays with different resolutions. The lower resolution (1600x1050) display was considered primary by the OS. I ran Tor Browser on the higher resolution display (1920x1200). Today I unplugged the smaller display and the Tor Browser window went back to normal size 1000x1000. It's like TBB was initially resizing the window based on the primary (lower resolution) display size, instead of which desktop the window was opened on.

comment:13 Changed 2 years ago by arthuredelstein

Keywords: TorBrowserTeam201702R added; TorBrowserTeam201702 removed
Status: assignedneeds_review

Here's my fix. There are three patches. The first just uses the full available pixels on screen instead of 95%. The second updates debugging code. And the third fixes Firefox's GTK code so that outerWidth/outerHeight takes the entire window into account, including system decorations.

https://github.com/arthuredelstein/tor-browser/commits/20905+2

comment:14 Changed 2 years ago by gk

Keywords: TorBrowserTeam201702 added; TorBrowserTeam201702R removed
Status: needs_reviewneeds_revision

I've built Linux bundles (and am currently building for other platforms as well) and tested the 64bit version on my Linux box. I get the attached screen shot on first start (note: the window width is even larger than the one of my monitor) and the following error in my terminal

*************************
A coding exception was thrown and uncaught in a Task.

Full message: TypeError: can't access dead object
Full stack: this.PromiseWalker.completePromise@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:700:9
TaskImpl_run@resource://gre/modules/Task.jsm:320:13
Handler.prototype.process@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:933:23
this.PromiseWalker.walkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:812:7
this.PromiseWalker.scheduleWalkerLoop/<@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:746:1

*************************

Let me know what you need from me to track this issue down.

Changed 2 years ago by gk

comment:15 Changed 2 years ago by gk

Keywords: TorBrowserTeam201703 added; TorBrowserTeam201702 removed

Moving tickets to March

comment:16 Changed 2 years ago by gk

Keywords: TorBrowserTeam201704 added; TorBrowserTeam201703 removed

Remmove remaining tickets over to April

comment:17 Changed 2 years ago by gk

Keywords: ff52-esr-will-have added
Resolution: fixed
Status: needs_revisionclosed

This seems to be fixed for me with the switch to ESR52. Please reopen if that is not the case on other machines/systems. This will make it into 7.0a3.

comment:18 Changed 2 years ago by arthuredelstein

This is fully fixed on Windows and Mac, but may still occasionally be noticeable on Linux, depending on the screen size and the size of toolbars, etc. Unfortunately a true fix for Linux is tricky because GTK is unable to report the height of a window's title bar before it is shown on screen. I opened #21945 to keep this problem in mind.

Note: See TracTickets for help on using tickets.