Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#21016 closed defect (not a bug)

Build break with libevent on CentOS 6.8

Reported by: cheekyrotter Owned by:
Priority: High Milestone:
Component: Core Tor/Tor Version: Tor: 0.2.9.7-rc
Severity: Major Keywords: libevent build break
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

The following error occurs on CentOS 6.8 with tor-0.2.9.7-rc:

checking for libevent directory... configure: WARNING: We found the libraries for libevent, but we could not find the C header files. You may need to install a devel package.
configure: WARNING: On most Redhat-based systems, you can get headers for libevent by installing the libevent-devel RPM package
configure: error: Missing headers; unable to proceed.
make: * No targets specified and no makefile found. Stop.
make:
* No rule to make target `install'. Stop.

The correct RPM is installed:

Package libevent-devel-1.4.13-4.el6.x86_64 already installed and latest version

CentOS 6.8 built tor-0.2.8.9 without errors.

Child Tickets

Change History (3)

comment:1 Changed 3 years ago by cheekyrotter

One major difference:

The tor_trydir check loop stops on (system) with tor-0.2.8.9, but it cycles through all of the choices with tor-0.2.9.7-rc.

A simple bit of instrumentation shows this:

TEST: tor_trydir []
TEST: tor_trydir [(system)]
TEST: tor_trydir [NONE]
TEST: tor_trydir usr/local
TEST: tor_trydir usr/pkg
TEST: tor_trydir opt/libevent

This probably means that the system file check for libevent no longer works for CentOS 6.8.

comment:2 Changed 3 years ago by yawning

Resolution: not a bug
Status: newclosed

Fedora and RHEL have a different idea on what major version should be called libevent. Fedora packages libevent-2.0.x as libevent, and it looks like Centos packages libevent-1.x.x. Support for the latter is deprecated, so the build being broken is expected. Perhaps the message could be improved but that's an orthogonal issue.

https://gitweb.torproject.org/tor.git/commit/?id=265e40b481d23ea0ee8b4e1705fb013532d1f6b2

comment:3 Changed 3 years ago by cheekyrotter

Then the documentation needs to be updated to reflect that libevent 1.x is no longer supported.

Note: See TracTickets for help on using tickets.