Opened 3 years ago

Closed 3 years ago

#21017 closed defect (worksforme)

Tor messenger doesn't play nice with torproject jabber server

Reported by: mrphs Owned by:
Priority: Medium Milestone:
Component: Archived/Tor Messenger Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I tried to use Tor Messenger to connect to tor project jabber server over onion and got the error that it doesn't recognize the cert. That was most probably because cert was issued to torproject.org and not to the onion address...

1) The error text was written in bright red on bright blue background. Make it extremely hard to read.

2) There's a tiny little link that says 'add an exception' if I didn't already know what it means and what it does I wouldn't have been able to locate that or accept the cert

3) Even after adding an exception, I got an error that I couldn't be authenticated to the server, while I could connect with the same settings using Coyim.

Child Tickets

Change History (5)

comment:1 Changed 3 years ago by mrphs

If this has to be separated tickets, please feel free to make changes.

comment:2 Changed 3 years ago by arlolra

That was most probably because cert was issued to torproject.org and not to the onion address...

Yes, that's expected.

1) The error text was written in bright red on bright blue background. Make it extremely hard to read.

That's because the account is highlighted (the bright blue). This is more apparent when you have more than one account. But I agree that it's less than ideal.

2) There's a tiny little link that says 'add an exception' if I didn't already know what it means and what it does I wouldn't have been able to locate that or accept the cert

This is #17517

3) Even after adding an exception, I got an error that I couldn't be authenticated to the server, while I could connect with the same settings using Coyim.

It's probably because you listed the onion as the domain instead of the server.

Can you try following the instructions listed here?
https://trac.torproject.org/projects/tor/ticket/17486#comment:1

I should move that, or similar, to the FAQ

For what it's worth, I can confirm that TM does work with the tpo xmpp server.

comment:4 Changed 3 years ago by arlolra

I would remiss not to also mention #13855 where known onions would be configured automatically.

Anyways, sorry for the poor usability.

comment:5 Changed 3 years ago by arlolra

Resolution: worksforme
Status: newclosed

Closing since these issues are covered elsewhere.

Note: See TracTickets for help on using tickets.