Opened 8 months ago

Closed 7 months ago

#21033 closed defect (fixed)

hs: HiddenServiceNumIntroductionPoints can't go below the default value of 3

Reported by: dgoulet Owned by: dgoulet
Priority: Medium Milestone: Tor: 0.3.0.x-final
Component: Core Tor/Tor Version:
Severity: Normal Keywords: tor-hs
Cc: Actual Points:
Parent ID: Points: 0.1
Reviewer: Sponsor: SponsorR-can

Description

With the HiddenServiceNumIntroductionPoints option, one should be able to go from 0 to the maximum allowed that is 10.

Currently, our code restrict from default value of 3 to the maximum value of 10. Bug is here:

      service->n_intro_points_wanted =
        (unsigned int) tor_parse_long(line->value, 10,
                                      NUM_INTRO_POINTS_DEFAULT,
                                      NUM_INTRO_POINTS_MAX, &ok, NULL);

Child Tickets

Change History (5)

comment:1 Changed 8 months ago by asn

Seems like a reasonable thing to fix.

As part of the fix, we should make sure that Tor behaves well if the value here is 0 (or 1).

comment:2 Changed 7 months ago by dgoulet

Owner: set to dgoulet
Status: newaccepted

comment:3 Changed 7 months ago by dgoulet

See branch bug21033_030_01.

Putting this one in merge_ready because it's trivial and asn acked the idea. I've tested this and I can confirm that the service uses the right amount of IPs respecting HiddenServiceNumIntroductionPoints

comment:4 Changed 7 months ago by dgoulet

Status: acceptedmerge_ready

comment:5 Changed 7 months ago by nickm

Resolution: fixed
Status: merge_readyclosed

merged!

Note: See TracTickets for help on using tickets.