Opened 10 months ago

Closed 9 months ago

#21038 closed task (invalid)

configure step and "implicit-function-declaration"

Reported by: toralf Owned by:
Priority: Medium Milestone: Tor: 0.3.0.x-final
Component: Core Tor/Tor Version: Tor: 0.3.0.1-alpha
Severity: Minor Keywords: configure gentoo
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

This breaks :

./configure CFLAGS="-O2 -pipe -march=native -Werror=implicit-function-declaration"
...
checking for pthread_create... yes
checking for pthread_condattr_setclock... yes
checking for libevent directory... configure: WARNING: We found the libraries for libevent, but we could not find the C header files.  You may need to install a devel package.
configure: error: Missing headers; unable to proceed.

but neither this :

./configure --enable-gcc-warnings

nor this

./configure CFLAGS="-O2 -pipe -march=native" --enable-gcc-warnings

Shouldn't the later break too ?

Child Tickets

Change History (4)

comment:1 Changed 10 months ago by nickm

Keywords: configure gentoo added
Milestone: Tor: 0.3.0.x-final

So the only difference seems to be the -Werror=implicit-function-declaration

comment:2 Changed 10 months ago by nickm

It shouldn't be necessary to add your own -Werror flags during the configure process -- doing that is likely to make autoconf fail to detect things (since autoconf detects stuff by trying to build it, and seeing whether there is an error).

comment:3 Changed 10 months ago by cypherpunks

This sounds like a duplicate of #19220.

comment:4 Changed 9 months ago by dgoulet

Resolution: invalid
Status: newclosed

Hrm, so yeah 1) bypassing autoconf is not ideal nor recommended I would say. But also, this doesn't break on my Linux machine so Gentoo could be mangling something with gcc? Also, does your gcc supports it?

I'll close this as I can't see any action items and #19220 seems a good start with this issue.

Note: See TracTickets for help on using tickets.