Opened 7 months ago

Closed 7 months ago

#21051 closed defect (fixed)

configure complains of missing libevent C-headers

Reported by: rainwolf Owned by:
Priority: High Milestone: Tor: 0.2.9.x-final
Component: Core Tor/Tor Version: Tor: 0.2.9.8
Severity: Major Keywords: regression review-group-14
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

The configure script aborts with the following output:

WARNING: We found the libraries for libevent, but we could not find the C header files.  You may need to install a devel package.

The test that fails complains of an implicit function declaration of event_init. This can be resolved by including the headers

event2/event_compat.h

I have attached the patch I used (taken from iCepa) to accomplish this.

Child Tickets

Attachments (2)

configure.ac.event-compat.diff (328 bytes) - added by rainwolf 7 months ago.
bug21051_v2.diff (566 bytes) - added by nickm 7 months ago.

Download all attachments as: .zip

Change History (8)

Changed 7 months ago by rainwolf

comment:1 Changed 7 months ago by nickm

  • Keywords regression added
  • Milestone set to Tor: 0.2.9.x-final
  • Priority changed from Medium to High
  • Status changed from new to needs_review

comment:2 Changed 7 months ago by nickm

Hm. Actually, it should probably look for event_base_new rather than event_init -- event_init is only a backward compatibility method for the libevent 1 API, and we don't support libevent 1 any more.

Changed 7 months ago by nickm

comment:3 follow-up: Changed 7 months ago by nickm

How about this one? (attached) It works okay for me.

(Also in a branch in my public repository as bug21051_v2.)

comment:4 Changed 7 months ago by nickm

  • Keywords review-group-14 added

comment:5 in reply to: ↑ 3 Changed 7 months ago by rainwolf

I confirm this works for me.

Replying to nickm:

How about this one? (attached) It works okay for me.

(Also in a branch in my public repository as bug21051_v2.)

comment:6 Changed 7 months ago by nickm

  • Resolution set to fixed
  • Status changed from needs_review to closed

Ok. Merging to 029 and forwards. Thanks!

Note: See TracTickets for help on using tickets.