Opened 9 years ago

Closed 8 years ago

#2107 closed defect (fixed)

When running a relay, Vidalia doesn't close when Windows shuts down

Reported by: arma Owned by:
Priority: Medium Milestone:
Component: Archived/Vidalia Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

When Tor is running as a relay, and you try to shut it down, it wants to wait ShutdownWaitLength seconds before Tor will close.

When Vidalia tries to stop Tor, Vidalia gives you the option to kill Tor right now or to wait until Tor closes on its own.

When Windows shuts down, it sends some signal to all the running apps to make them close nicely.

People who run Tor relays under Vidalia on Windows report that sometimes Windows complains that Vidalia hasn't closed during shutdown.

Is Vidalia failing to do the "quick kill" thing on Tor when it gets the "shutting down" signal from Windows?

See also https://trac.vidalia-project.net/ticket/501

Child Tickets

Change History (2)

comment:1 Changed 8 years ago by rransom

See also #2945.

comment:2 Changed 8 years ago by chiiph

Resolution: fixed
Status: newclosed

I've looked at the code for this, and what Vidalia does is to send a SIGNAL HALT to stop tor properly. I tried using that signal on a plain controlport connection with telnet, and it works perfectly.

Basically, I couldn't reproduce this with the latest TBB on Windows 7. I'm going to close this as fixed for now until someone comes up with the steps to properly reproduce it.

This might've been a bug with Qt 4.5 and QProcess, which got fixed in 4.6, I'm not sure.

Note: See TracTickets for help on using tickets.