Opened 3 years ago

Closed 3 years ago

#21076 closed defect (fixed)

failed to initialize user interface: open /home/user/.local/share/sandboxed-tor-browser/tor-browser/Browser/defaults/pref/autoconfig.js

Reported by: adrelanos Owned by: yawning
Priority: Medium Milestone:
Component: Archived/Tor Browser Sandbox Version:
Severity: Normal Keywords:
Cc: whonix-devel@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Started sandboxed-tor-browser with broken system control port (answering "filtered"). On second start of sandboxed-tor-browser the following will happen.

./bin/sandboxed-tor-browser
2016/12/25 04:52:34 failed to initialize user interface: open /home/user/.local/share/sandboxed-tor-browser/tor-browser/Browser/defaults/pref/autoconfig.js: no such file or directory

And refuse to start.

Workaround:

rm -r .config/sandboxed-tor-browser

Child Tickets

Change History (5)

comment:1 Changed 3 years ago by yawning

I don't see myself being able to reproduce this to debug it. If there's root cause diagnosis of why this happens, or patches that would be helpful. I also don't have the time to make all the bits that talk to the control port play nice with something that is out of spec.

Last edited 3 years ago by yawning (previous) (diff)

comment:2 Changed 3 years ago by yawning

Status: newneeds_information

Both of these require more investigation on a platform I do not have ready access to, before I can even begin to fix them.

comment:3 Changed 3 years ago by yawning

Debug output would probably be a good start here, and may provide insight into what's going wrong since I doubt it's the control port that's the root cause.

comment:4 Changed 3 years ago by yawning

Oh I see what's going on here. I assume this is on something newer than 0.0.2, because c168f0854cec19a55d5401ae822c450e64760ef7 is the change that introduced the behavior. I'm fairly sure that if the install process fails, and you update to a binary that's on a different git revision, it will get unhappy.

comment:5 Changed 3 years ago by yawning

Resolution: fixed
Status: needs_informationclosed
Note: See TracTickets for help on using tickets.