Opened 10 months ago

Closed 5 months ago

#21120 closed defect (duplicate)

evdns_get_orig_address: tor_fragile_assert() warning for unknown rtype.

Reported by: mr-4 Owned by:
Priority: High Milestone: Tor: 0.3.1.x-final
Component: Core Tor/Tor Version:
Severity: Normal Keywords:
Cc: Actual Points: 0
Parent ID: Points: 0
Reviewer: Sponsor:

Description

The trace (below) appeared while routinely examining my tor log while having network connectivity issues (arch is x86/32 bit, kernel is 3.11):

Jan 02 16:22:56.000 [warn] {BUG} tor_bug_occurred_(): Bug: src/or/dnsserv.c:294: evdns_get_orig_address: This line should not have been reached. (Future instances of this warning will be silenced.) (on Tor 0.2.9.4-alpha 8b0755c9bb296ae2)
Jan 02 16:22:56.000 [warn] {BUG} Bug: Line unexpectedly reached at evdns_get_orig_address at src/or/dnsserv.c:294. Stack trace: (on Tor 0.2.9.4-alpha 8b0755c9bb296ae2)
Jan 02 16:22:56.000 [warn] {BUG} Bug:     /usr/bin/tor(log_backtrace+0x56) [0xb765aee6] (on Tor 0.2.9.4-alpha 8b0755c9bb296ae2)
Jan 02 16:22:56.000 [warn] {BUG} Bug:     /usr/bin/tor(tor_bug_occurred_+0xf5) [0xb7676435] (on Tor 0.2.9.4-alpha 8b0755c9bb296ae2)
Jan 02 16:22:56.000 [warn] {BUG} Bug:     /usr/bin/tor(dnsserv_resolved+0x255) [0xb7642435] (on Tor 0.2.9.4-alpha 8b0755c9bb296ae2)
Jan 02 16:22:56.000 [warn] {BUG} Bug:     /usr/bin/tor(connection_ap_handshake_socks_resolved+0x8e) [0xb75fe4fe] (on Tor 0.2.9.4-alpha 8b0755c9bb296ae2)
Jan 02 16:22:56.000 [warn] {BUG} Bug:     /usr/bin/tor(+0x593fe) [0xb75513fe] (on Tor 0.2.9.4-alpha 8b0755c9bb296ae2)
Jan 02 16:22:56.000 [warn] {BUG} Bug:     /usr/bin/tor(+0x5d296) [0xb7555296] (on Tor 0.2.9.4-alpha 8b0755c9bb296ae2)
Jan 02 16:22:56.000 [warn] {BUG} Bug:     /usr/bin/tor(circuit_receive_relay_cell+0x316) [0xb7556f66] (on Tor 0.2.9.4-alpha 8b0755c9bb296ae2)
Jan 02 16:22:56.000 [warn] {BUG} Bug:     /usr/bin/tor(command_process_cell+0x22f) [0xb75d8f0f] (on Tor 0.2.9.4-alpha 8b0755c9bb296ae2)
Jan 02 16:22:56.000 [warn] {BUG} Bug:     /usr/bin/tor(channel_queue_cell+0xd2) [0xb75b0882] (on Tor 0.2.9.4-alpha 8b0755c9bb296ae2)
Jan 02 16:22:56.000 [warn] {BUG} Bug:     /usr/bin/tor(channel_tls_handle_cell+0x2bc) [0xb75b695c] (on Tor 0.2.9.4-alpha 8b0755c9bb296ae2)
Jan 02 16:22:56.000 [warn] {BUG} Bug:     /usr/bin/tor(+0x11095b) [0xb760895b] (on Tor 0.2.9.4-alpha 8b0755c9bb296ae2)
Jan 02 16:22:56.000 [warn] {BUG} Bug:     /usr/bin/tor(+0xf8df4) [0xb75f0df4] (on Tor 0.2.9.4-alpha 8b0755c9bb296ae2)
Jan 02 16:22:56.000 [warn] {BUG} Bug:     /usr/bin/tor(connection_handle_read+0x7e3) [0xb75f9983] (on Tor 0.2.9.4-alpha 8b0755c9bb296ae2)
Jan 02 16:22:56.000 [warn] {BUG} Bug:     /usr/bin/tor(+0x3458f) [0xb752c58f] (on Tor 0.2.9.4-alpha 8b0755c9bb296ae2)
Jan 02 16:22:56.000 [warn] {BUG} Bug:     /usr/lib/libevent-2.1.so.6(+0x207d5) [0xb745a7d5] (on Tor 0.2.9.4-alpha 8b0755c9bb296ae2)
Jan 02 16:22:56.000 [warn] {BUG} Bug:     /usr/lib/libevent-2.1.so.6(event_base_loop+0x2b4) [0xb745af84] (on Tor 0.2.9.4-alpha 8b0755c9bb296ae2)
Jan 02 16:22:56.000 [warn] {BUG} Bug:     /usr/bin/tor(do_main_loop+0x46c) [0xb752732c] (on Tor 0.2.9.4-alpha 8b0755c9bb296ae2)
Jan 02 16:22:56.000 [warn] {BUG} Bug:     /usr/bin/tor(tor_main+0x1315) [0xb7528965] (on Tor 0.2.9.4-alpha 8b0755c9bb296ae2)
Jan 02 16:22:56.000 [warn] {BUG} Bug:     /usr/bin/tor(main+0x33) [0xb7523e23] (on Tor 0.2.9.4-alpha 8b0755c9bb296ae2)
Jan 02 16:22:56.000 [warn] {BUG} Bug:     /lib/libc.so.6(__libc_start_main+0xe6) [0xb7033cc6] (on Tor 0.2.9.4-alpha 8b0755c9bb296ae2)
Jan 02 16:22:56.000 [warn] {BUG} Bug:     /usr/bin/tor(+0x2bd11) [0xb7523d11] (on Tor 0.2.9.4-alpha 8b0755c9bb296ae2)

Child Tickets

Change History (4)

comment:1 Changed 8 months ago by nickm

Milestone: Tor: 0.3.1.x-final

comment:2 Changed 7 months ago by nickm

Points: 1
Priority: MediumHigh

comment:3 Changed 6 months ago by nickm

Summary: evdns_get_orig_addressevdns_get_orig_address: tor_fragile_assert() warning for unknown rtype.

comment:4 Changed 5 months ago by nickm

Actual Points: 0
Points: 10
Resolution: duplicate
Status: newclosed

After a bit of investigation -- I am pretty sure this is a duplicate of #19869, fixed in 0.2.9.5-alpha.

Note: See TracTickets for help on using tickets.