Opened 9 years ago

Closed 8 years ago

#2117 closed defect (fixed)

our rpm packages require privoxy

Reported by: phobos Owned by: marlowe
Priority: Medium Milestone:
Component: Core Tor/RPM packaging Version:
Severity: Keywords: privoxy dependencies, rpm packages, easy
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

According to an opensuse user, our rpms require privoxy as part of the installation. We shouldn't require any http proxy to install tor or vidalia from our repo.

Child Tickets

Change History (3)

comment:1 Changed 9 years ago by erinn

Keywords: easy added

comment:2 Changed 8 years ago by Sebastian

Component: Tor bundles/installationRPM packaging
Owner: changed from erinn to marlowe

comment:3 Changed 8 years ago by marlowe

Resolution: fixed
Status: newclosed

A search through the tor.spec.in for requiring privoxy turns up nothing.

[marlowe@statler tor]$ grep -i require tor.spec.in
Requires: openssl >= 0.9.7
BuildRequires: openssl-devel >= 0.9.7, rpm >= 4.0, zlib-devel
Requires: openssl >= 0.9.7
BuildRequires: openssl-devel >= 0.9.7
BuildRequires: rpm-build >= 4.0
Requires(pre): /usr/bin/id, /bin/date, /bin/sh
Requires(pre): %{_sbindir}/useradd, %{_sbindir}/groupadd

# require thought.
# also require thought.

  • add logic for SuSE since it requires special doc handling

Marking this as fixed.

Note: See TracTickets for help on using tickets.